1

Hey guys hope you're doing well, I have an interesting issue that has persisted since I started working that is becoming more and more of a hassle.

In the Admin Panel when I go to Catalog-->ManageProducts-->Click on a Product then on the left click "Images"

I click on "Browse Files" and select an image: enter image description here

Then I click on "Upload Files" and I get:enter image description here

The problem now is that I select that image for 'Base Image', 'Small Image', and 'Thumbnail' and click "Save and Continue Edit" which results in: enter image description here

This is super annoying because I have to manually upload images and this makes it take about twice as long. Where is the controller for this function in the admin? Is the Save and Continue Edit calling an extra product->save() somewhere?

  • Same issue here. But this wasn't happening before. I think it's cause by one of my recently installed modules or some admin modifications that I forgot to track and test the image upload thing. – jehzlau Oct 12 '17 at 14:59
  • Did you recently installed any new modules or you have any observers in your own custom module that's saving a product? – jehzlau Oct 12 '17 at 15:09
1

I found out that we have a custom module with an observer and has a $product->save() before the end of the function. And it's forcing to save the product twice.

You can check if you have any recent custom modules that saves the product. Just remove the "$product->save();" in the end of the function and it will resolve the issue. :D

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.