0

When logging into Magento (v2.1.2), I am able to successfully login using my password, and then I am immediately redirected to an account page that states 'It's time to change your password'.

Upon updating the password, Magento will not accept any value I enter into it, always displaying the error message

Sorry, but this password has already been used. Please create another.

I know there's no possible way all the combinations I've tried using have previously been used, even making up completely new passwords to try.

I've also manually updated the admin users password through the mysql database, and upon logging in get thrown into the same loop.

Has anybody else dealt with this issue, or have any suggestions?

6

I was able to resolve this issue by going into the admin_passwords table, and removing the stored passwords associated with the admin users' ID.

Not sure if this was the right way to go about it, but it solved this issue and hasn't caused any adverse effects, as far as I can tell.

1
  • Go to Admin-Configuration-Advanced-Admin-Security
  • Remove "Password lifetime" value
  • Good to know, will note, but would not have been able to access that settings page without first fixing the password issue itself. – codestr Apr 28 '17 at 8:36
  • For those looking for option in M2.1: Stores > Configuration > Advanced > Admin > Security > Password Lifetime (days) – PassTeT Sep 5 '17 at 15:34
0

We have face the same, and follow the below steps for resolve the issue.

  1. Going to admin_passwords table. And change the last_updated column value (current date use the code echo strtotime("now"); ).

  2. Save and login in shop admin everything working properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.