0

Default magento captcha i set all configurations and added in custom form

       <?php echo $block->getChildHtml('catcaptcha');?>

In my local it was working , but in prodcution its not working.

  • It may be permission issue. Try to give full permission to var/* and pub/*. – Nits Apr 27 '17 at 10:20
  • already given @Nits – Nadh Apr 27 '17 at 10:23
  • Is anything effect with https? – Nadh Apr 27 '17 at 11:36
0

I was facing the same issue before and in my case it was caused by my theme's customer_account_login.xml file.

I was facing the same issue before and in my case it was caused by my theme's customer_account_login.xml file.

For example, if your theme is extending Magento_Blank theme, then you don't need to copy the entire contents of the customer_account_login.xml file to your theme to make changes to it --> this will "bug out" the CAPTCHA form.

The proper way to make changes is to use and to add, remove or move the elements as you want.

You can read instructions here on how to do that: http://devdocs.magento.com/guides/v2.2/frontend-dev-guide/layouts/xml-instructions.html

If you are facing the same issue, you can quickly test it by renaming/removing your theme's customer_account_login.xml and clearing cache.

Ref: CAPTCHA form not visible, after applying theme

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.