1

after copying locally on XAMPP my magento I get the attached image

These are the steps that I followed: Steps for a Magento 1.9 copy in local: 1. Copy all folders 2. Export database from remote server 3. Import database to local server 4. Change URLs in the core_config_data table 5. Change the parameters in the /app/etc/local.xml file 6. Replace .htaccess files (resume the original file, even clean the installation file)enter image description here

  • check the image and css file path if they give forbidden then give 777 permision. – Qaisar Satti Apr 26 '17 at 10:36
0

You're url is localhost://magento1_9/localhost/magento1_9 which is incorrect. Check your .htaccess file in the root of your site and where you have:

############################################
## you can put here your magento root folder
## path relative to web root

    #RewriteBase /

make sure that it's correct. In my case, i'm running MAMP so i don't need it, but in some cases you need to make sure your base is just /.

If that doesn't clear things up, take a look at you DB (should be easy with phpMyAdmin) in the core_config_data table. There are rows for your site's path under web/unsecure/base_url and web/secure/base_url. For me, i have to run these as http://127.0.0.1:8888/magento_19/ as magento doesn't play nice with localhost for setting cookies.

  • On the db i set it up like this: Web/unsecure/base_url localhost/clone_magento1_9_26042017/ Web/secure/base_url Localhost/clone_magento1_9_26042017/ On my htaccess is written as follows: #################################### ## you can put here your magento root folder ## path relative to web root #RewriteBase / magento / #################################### – Riccardo May 1 '17 at 8:49
  • Try putting both DB values to http://127.0.0.1:8888/clone_magento1_9_26042017/. The 8888 in my url is for my set up of MAMP, your apache port might be different. To check that, go into the preferences of XAMPP and check what your default Apache port is set to. Your .htaccess file might be fine that way, but i find that setting it to RewriteBase / works for me on my system. Just take out the # and the rule will apply. Playing with these setting will most likely solve the issue. – circlesix May 1 '17 at 14:13
0
  1. Please check you give correct url and make sure you are give url end "/". E.g "http://www.sample.com" to "http://www.sample.com/"

    2.Make sure the url is define based on store

  2. Make sure your javascript and css is unmerge status.

  3. Make sure you clear the cache.

  • 2.Make sure the url is define based on store 2.Make sure your javascript and css is unmerge status. What do these two steps mean? – Riccardo Apr 30 '17 at 12:19
0

I think that you have not correct settings for folder media and var Please see here

In general all files should be 644 and all folders should be 755 and should be owned by the user your web server runs under. The mage executable should be given 550 permissions to allow execution.

This shell script should patch things up if run from your Mage root:

#!/bin/sh
find . -type f -exec chmod 644 {} \;
find . -type d -exec chmod 755 {} \;
chmod 550 mage
  • Hello and thank you for the kind reply I'm not very practical about the xampp shell I started xampp, then shell, I entered the magento root, and then I pasted this script by mistake. I use Xampp for Windows.Could you explain how I should do it? thank you – Riccardo Apr 27 '17 at 10:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.