1

I installed a module and the files are correct and the commands worked just fine but when I go to System > Advanced, it doesn't show up in the disable modules section at all but it shows up when I run module:status and it says enabled.

This is what I tried so far after installing the module:

  • Ran module:status and it shows as enabled
  • Ran setup:db-schema:upgrade
  • Ran setup:db-data:upgrade
  • Flushed all cache
  • Checked /app/etc/config.php and it shows up there
  • Switched to developer mode and back to production mode
  • Installed module in developer and production mode but no change
  • Installed old version of the same module that worked before and no change
  • Deleted entries from setup_module table and then redid install

Database related maybe?

UPDATE: After many attempts, I was finally able to see the module enabled in the System > Advanced > Modules section but I'm still not able to see the module section under the Store > Configuration so how can I get the module to install the necessary code to make that happen?

  • Is there registration.php file ? – Kishan Patadia Apr 25 '17 at 19:33
  • @KishanPatadia Yes there is – user3610374 Apr 25 '17 at 19:54
1

After installing module

delete your generation and cache folder inside var

Run setup:upgrade

Run static-content:deploy

  • read my details because I already did all of that – user3610374 Apr 25 '17 at 16:00
  • you can check in log files. if there is any error showing there. Also try to delete pub/static (require,frontend,adminhtml) and than repeat the steps. – Amit Singh Apr 25 '17 at 16:04
  • tried that and it didn't work – user3610374 Apr 25 '17 at 16:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.