2

I created a new theme but when i tried to change the theme from

stores -> configuration -> design Tab I found that theme change field is missing from design tab. Please look at screen-shot below. Can anyone tell me why theme change field is not coming. I am using Magento ver. 2.1.5.

enter image description here

4

As of Magento 2.1.x they have moved themes into content=>design enter image description here

  • Correct answer, though an odd decision. A theme is not normally considered a part of the content. – ACJ 2 days ago
1

First check that your theme structure looks like this under,

app/design/frontend/<vendor>/
├── <theme>/
│   ├── etc/
│   │   ├── view.xml
│   ├── web/
│   │   ├── images
│   │   │   ├── logo.svg
│   ├── registration.php
│   ├── theme.xml
│   ├── composer.json

Check all the files properly. And delete var/generation files and then refresh any admin page having added the theme files to the files system, your theme gets registered and added to the database And also delete any entry made in database of your theme ,if any.
Or you can send your code so i can check whats's wrong. Hope this helps you..

  • I delete my theme and cleared cache, but still theme fields are missing. It is missing in default Magento 2.1.5 version. Can you tell me how to add this. – BornCoder Apr 25 '17 at 12:57
  • Make sure you have deleted the theme from database also.And then try to find the theme under :- Content > Theme. Not under configuration. – user53061 Apr 26 '17 at 7:18
0

Run these commands to enable the developer mode, to disable the cache and etc:

alias mage="php -d memory_limit=-1 -f bin/magento"
mage deploy:mode:set developer
chmod -R 775 pub/static/ var/ pub/media/ &&
rm -rf var/view_preprocessed/ var/cache/ var/page_cache/ var/tmp/ var/generation/ pub/static/frontend/ ;
mage cache:disable &&
mage indexer:reindex &
mage setup:upgrade &&
mage setup:static-content:deploy && 
mage setup:db-data:upgrade &&
mage dev:source-theme:deploy &&
chmod -R 775 pub/static/ pub/media/ var/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.