All of a sudden I cannot log into Magento, at all.

I used the .htaccess to force SSL. This broke things so I have turned it off again.

It started with another User being unable to log in. Meanwhile I still could. No I cannot log in nor any other users.

I get no errors and submitting the log in form just redirects to /index.php/admin/index/index/key/bbdbb9580dbc6aec7b25c9cd96277058/ with no errors at all.

Nothing has changed other than turning on SSL and then turning it off via the .htaccess file. Apache has been restarted too.


If I use the password reset form and reset my password and then log in it works. Log out and it fails again.

  • Have you cleared your cache? In last resort you could delete all sessions in /var/session/. Apr 25, 2017 at 9:31
  • I just tried that, no change. Is there any other cache folder I can delete?
    – Jake N
    Apr 25, 2017 at 9:32
  • All cache folders are under /var/cache. Could you specify the Magento version you are using? Are you using something like Memcached for sessions? Apr 25, 2017 at 9:34
  • Not memcache. How can I find the version, its usually at the bottom when I log in. But I cannot log in.
    – Jake N
    Apr 25, 2017 at 9:34
  • You can find the version inside app/Mage.php Apr 25, 2017 at 9:35

1 Answer 1


Depending on your configuration, remember you may be using REDIS or Memcached for your cache, so clearing that folder might or might not help.

This looks like it has successfully logged you in, but it's still showing you the login page.

This usually relates to the cookie domain.

Firstly, clear your BROWSER cache & sessions, or try incognito.

Secondly, take a look in your database for rows with the path "web/cookie/cookie_path" and "web/cookie/cookie_domain" in your core_config_data table. It might be that you updated this value, and you need to revert it.

You may also find that if you have multiple Magento admin logins running on subdomains, that this issue is caused by setting the cookie domain to act for all subdomains. This means you can login, but you'll always be shown the login page. Always a pain on development enviornments!

  • There is now way I am using REDIS or Memcached. I have been using different browsers and incognito to try and log in. All result in the same issue, no errors and no log in. web/cookie/cookie_pat value is NULL and web/cookie/cookie_domain value is NULL. The site has no sub domains and is not on a subdomain.
    – Jake N
    Apr 25, 2017 at 10:06
  • Did you get to the bottom of this? May 3, 2017 at 13:50
  • It seemed to just work one day
    – Jake N
    May 4, 2017 at 12:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.