3

This question already has an answer here:

Your current PHP memory limit is 128M. Magento 2 requires it to be set to 756M or more. As a user with root privileges, edit your php.ini file to increase memory_limit. (The command php --ini tells you where it is located.) After that, restart your web server and try again.

i am trying the above but its not working for me .can anyone help me how to solve this ?

marked as duplicate by Rakesh Jesadiya, Murtuza Zabuawala, Siarhey Uchukhlebau, Ashish Jagnani, David Manners Apr 27 '17 at 11:51

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Apply changes in php.ini Apache – Ankit Shah Apr 25 '17 at 4:31
  • Find which php.ini your system is using. Open the file with text editor and search for memory_limit, Increase the value from 128M to 756M or more, save the php.ini file. Restart the web server and you should ready to go. – Nikola Apr 25 '17 at 4:34
  • i did this already but its not working .after restarting again showing the same error. – Ashish Apr 25 '17 at 4:39
  • @Ashish Which is your Webserver? Apache or Nginx? – Khoa TruongDinh Apr 25 '17 at 4:59
  • Apache is my Webserver. – Ashish Apr 25 '17 at 6:43
0

You maybe applied the changes in the wrong php.ini (since there's so many of them, especially in an old system ...)

Try finding the correct one as shown here magento 2.1 Doc PHP Settings

To find the PHP configuration file, php.ini:

To find the web server configuration, run a phpinfo.php file in your web browser and look for the Loaded Configuration File as follows

or add phpinfo() function in the index.php like :

<?php
/**
 * Application entry point ...
 */

phpinfo(); die;

try {
   require __DIR__ . '/app/bootstrap.php';
}

you can try looking for memory limit there.

Not the answer you're looking for? Browse other questions tagged or ask your own question.