0

I am trying to install some extension with the way thats described in the docs.

I uploaded the unziped folder in my root directory and ran the command php f bin/magento setup:upgrade

this threw me the following error: Could not open input file: f

So I tried to replace f with the folder of my extension and entered

php dpd_magento bin/magento setup:upgrade

but nothing happened.

When I do it without the dpd_magento it works through some process but the extension, doesn't seem to be installed either way.

Edit

Seems that the module name is stated wrong - I can't find anything thats matching the commented name - see the following screenshot:

enter image description here

3 Answers 3

0

Below is the code to activate module

In your magento root folder open ctrl+shift - open window command and paste

php bin/magento setup:upgrade

Then you need to deploy static content after cleaning the cache

php bin/magento cache:clean

php bin/magento setup:static-content:deploy

0

edit:

You try to install a Magento 1.x module to Magento 2.x. Those are not compatible.


You mistyped the command, it should be:

bin/magento module:enable dpd_magento

{magento executable} module:{command} {your module name}

For further information see: http://devdocs.magento.com/guides/v2.0/install-gde/install/cli/install-cli-subcommands-enable.html

Alternatively you can execute as a php command like:

php bin/magento module:enable dpd_magento
8
  • php bin/magento module:enable dpd_magento throws Unknown module(s): 'dpd_magento'
    – noa-dev
    Commented Apr 24, 2017 at 13:58
  • That's because it's not the correct module name then. Go to the app code folder and look for a folder named like this <vendor>_<modulename>. That's the string you need to put in then. This also only works if you put the module at the right place.
    – steros
    Commented Apr 24, 2017 at 14:09
  • I updated my question
    – noa-dev
    Commented Apr 24, 2017 at 14:13
  • You misplaced your code. You need to put the app/code directory in dpd_magento into the magento app/code directory. Better way would be to install via composer if that method is available.
    – steros
    Commented Apr 24, 2017 at 14:14
  • But on a second thought...I edited my answer.
    – steros
    Commented Apr 24, 2017 at 14:16
-1

You can do it without adding 'f'

try just simple one, like

Step : 1 Go to root folder and run,

php bin/magento module:enable Module_Name

php bin/magento setup:upgrade

Step: 2

php bin/magento setup:di:compile

Step: 3

php bin/magento cache:flush

Step: 4

php bin/magento module:status

and see the status of your module

8
  • php bin/magento module:enable dpd_magento throws Unknown module(s): 'dpd_magento'
    – noa-dev
    Commented Apr 24, 2017 at 13:58
  • try the command php bin/magento module:status first Commented Apr 24, 2017 at 14:01
  • and see wheather your module is listed in the disabled module list or not Commented Apr 24, 2017 at 14:01
  • It it is listed in the disabled module list, then type the name exactly similar to shown in the list, and then write php bin/magento module:enable YOUR_MODULE_NAME Commented Apr 24, 2017 at 14:02
  • Its not listed in either one of the lists ...
    – noa-dev
    Commented Apr 24, 2017 at 14:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.