0

When submitting extension to Magento2 Marketplace gives error "Error During Installation Command returned non-zero exit code".

Environment: Operating System - Centos 7, PHP Version - 5.6.30, Magento Platform - 2.0.13 CE Command: deploy:mode:set production

While I am able to install and command "deploy:mode:set production" showing no error on my end.

Please help me if anyone encountered the same problem. Thanks In advance.

4
  • It may due to compilation errors. Run setup:di:compile and look for any errors. If so, fix it and move to production. – Mike Apr 20 '17 at 12:44
  • I already tried to run setup:di:compile command. But Found no error in this. Magento marketplace testing extension on "Magento Platform - 2.0.13 CE" When I install this version on localhost. This gives me same error as i listed in question when run command "deploy:mode:set production". However I didn't install my extension yet on this magento installation. – Mohit chauhan Apr 21 '17 at 6:59
  • Anyone there who can faced the same issue ? – Mohit chauhan May 12 '17 at 11:44
  • I am facing same issue, Getting errors from the MarketPlace, however, there are no errors in module. Did you get solution for it ? – SyncTechnolab Dec 19 '19 at 16:42
0

This error means that the extension prevents product and category pages from being cached by Varnish. One possible cause is using cacheable="false" in one or more blocks on product and category pages.

Additional resources: https://devdocs.magento.com/guides/v2.4/config-guide/varnish/config-varnish.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.