I'm trying to install magento data migration tool for magento 2.1.6, while on ssh session, i get an error message saying: Package fabpot/php-cs-fixer is abandoned, you should avoid using it. Use friends ofphp/php-cs-fixer instead following the advice on that post

I tried changing the "fabpot/php-cs-fixer": "~1.2" with "friendsofphp/php-cs-fixer": "~2.0" on the composer.json rerun, but the problem appeared once again. I tried to edit the json.lock, but it doesn't have "fabpot/php-cs-fixer": "~1.2"

just "fabpot/php-cs-fixer": "0.4.0" and "fabpot/php-cs-fixer": "1.7.*"

any advice how to proceed?

  • I know, you already linked that question, but it's the same problem - you might want to add your answer there. Commented Apr 23, 2017 at 9:20
  • i asked the question there too, but it was deleted, i guess i shouldn't post "me too" questions
    – S.Mikhail
    Commented Apr 23, 2017 at 9:27
  • That's right, but now that you have an answer, feel free to add it there. If it is an addition to an existing answer, you can also add a comment instead. Commented Apr 23, 2017 at 9:31
  • i can't comment yet, i've under 50 reputation. about your post there, the migration tool won't be installed because of that warning.
    – S.Mikhail
    Commented Apr 23, 2017 at 9:40

1 Answer 1


I was able to resolve that through updating the composer.jason file by replacing

"fabpot/php-cs-fixer": "~1.2"


"friendsofphp/php-cs-fixer": "~2.0"

and on the composer.lock replacing

"fabpot/php-cs-fixer": "0.4.0"


"friendsofphp/php-cs-fixer": "0.4.0"

and replacing

"fabpot/php-cs-fixer": "1.7.*"


"friendsofphp/php-cs-fixer": "2.0.*"

Not the answer you're looking for? Browse other questions tagged or ask your own question.