0

I have submitted my module in magento 2 marketplace. My module got rejected on technical review and shown below error:

Environment: Operating System - Centos 7, PHP Version - 5.6.30, Magento Platform - 2.1.5 CE

Command: composer require propellents/testimonials:1.0.0' Installation issue: Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for magento/magento2ce 2.1.5 -> satisfiable by magento/magento2ce[2.1.5].
- propellents/testimonials 1.0.0 requires magento/framework ~100.0.4 -> satisfiable by magento/framework[100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.0.8, 100.0.9, 100.0.10, 100.0.11, 100.0.12, 100.0.13, 100.0.14, 100.0.15].
- don't install magento/framework 100.0.4|remove magento/magento2ce 2.1.5
- don't install magento/framework 100.0.5|remove magento/magento2ce 2.1.5
- don't install magento/framework 100.0.6|remove magento/magento2ce 2.1.5
- don't install magento/framework 100.0.7|remove magento/magento2ce 2.1.5
- don't install magento/framework 100.0.8|remove magento/magento2ce 2.1.5
- don't install magento/framework 100.0.9|remove magento/magento2ce 2.1.5
- don't install magento/framework 100.0.10|remove magento/magento2ce 2.1.5
- don't install magento/framework 100.0.11|remove magento/magento2ce 2.1.5
- don't install magento/framework 100.0.12|remove magento/magento2ce 2.1.5
- don't install magento/framework 100.0.13|remove magento/magento2ce 2.1.5
- don't install magento/framework 100.0.14|remove magento/magento2ce 2.1.5
- don't install magento/framework 100.0.15|remove magento/magento2ce 2.1.5
- Installation request for propellents/testimonials 1.0.0 -> satisfiable by propellents/testimonials[1.0.0].


    Installation failed, reverting ./composer.json to its original content.
    [Pipeline] }
    [Pipeline] // stage
    [Pipeline] sh
    [DockerOperationsPHP56Magento21CE] Running shell script
    + echo Failure
    Failure  

After solving above error now I am getting below error.

Environment: Operating System - Centos 7, PHP Version - 7.0.15, Magento Platform - 2.0.13 CE

Command: deploy:mode:set production
Installation issue: Enabled maintenance mode
Static content deployment start
Requested languages: en_US
Requested areas: adminhtml, frontend
Requested themes: Magento/backend, Magento/blank, Magento/luma
=== adminhtml -> Magento/backend -> en_US ===
=== frontend -> Magento/blank -> en_US ===
=== frontend -> Magento/luma -> en_US ===
......................................................................................................................................................
Successful: 2054 files; errors: 0
---

..
Successful: 1981 files; errors: 0
---


Successful: 1849 files; errors: 0
---

=== Minify templates ===

Successful: 854 files modified
---

New version of deployed files: 1492507317
Static content deployment complete
Start compilation
Command returned non-zero exit code:
`php -f /var/www/html/bin/magento setup:di:compile-multi-tenant 2>&1`
+ '[' ']'
[Pipeline] }
[Pipeline] // stage
[Pipeline] stage
[Pipeline] { (indexer:reindex)
[Pipeline] sh  

Anyone who can help. I have prepared my module and about to publish it. But not able to rectify this issue. Please help me to solve the issue.

  • Please first accept answers in your previous questions to help the community – Keyur Shah Apr 18 '17 at 8:57
  • Your answer didn't help me. – Gaurav Agrawal Apr 18 '17 at 9:07
  • I am not talking about only my answer :), I can see 2-3 more questions in your profile and which are unaccepted – Keyur Shah Apr 18 '17 at 9:24
  • It may be the same reason @KeyurShah otherwise I always accept if it is usefull for me. – Gaurav Agrawal Apr 18 '17 at 9:36
4

You can remove the unwanted module's references in composer.json require block.

"require": {
        "php": "~5.6.5|7.0.2|7.0.4|~7.0.6"
}

Just keep the PHP version dependency or provide the latest version of the dependency module.

For this module, instead of magento/framework ~100.0.4, try magento/framework ~100.1.* which ensures your module depends on latest version of magento framework module.

  • I have removed that and it removed my previous error. But now it is showing different error. Please check it on my question – Gaurav Agrawal Apr 18 '17 at 9:33
  • I guess this is because of compilation errors. Try running bin/magento setup:di:compile and look for any duplicate dependency errors. Once you fixed that, this will be solved – Mike Apr 18 '17 at 10:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.