0

I created a Magento 2.1 project successfully in a Jailkit jail. Running the html setup Readiness Check, the file permissions fail, because Magento is trying to use the root user's path, rather than the jail path.

"/var/www/clients/client0/web10/web/magento2/app/etc" - Not writable, change the permissions. Show details
"/var/www/clients/client0/web10/web/magento2/var" - Not writable, change the permissions. Show details
"/var/www/clients/client0/web10/web/magento2/pub/media" - Not writable, change the permissions. Show details
"/var/www/clients/client0/web10/web/magento2/pub/static" - Not writable, change the permissions. Show details

(Actual path is: "/web/magento2/...")

How can I set the actual Magento base path?

The command "pwd" responds with the correct path, "/web/magento2", but Magento is clearly looking at the ROOT user's path, rather than the jail's path.

I already tried setting permissions, and since we're in a jail, none of the jail users can use the full path either.

  • your path in jail is incorrect, looks like jail is not working at all, how can you see full path then??? magento installator must see only chroot. – MagenX Apr 17 '17 at 21:18
1

Access your Magento root folder and run this command below:

find var vendor pub/static pub/media app/etc -type f -exec chmod g+w {} \;
find var vendor pub/static pub/media app/etc -type d -exec chmod g+ws {} \;
chmod u+x bin/magento

Magento documentation reference.

  • Thanks! That corrected the issue. I'll remember that in future. – MontyThreeCard Apr 17 '17 at 20:26
  • this is nonsense, because his question was about path, not permissions... and his chroot path is wrong – MagenX Apr 17 '17 at 21:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.