7

Using Magento 2.1.5, I am trying to change the Catalog Price Scope option to Website from Global in Stores > Configuration > Catalog > Catalog > Price, but I cannot as it is disabled.

I have got 2 websites, each with one store and one store view.

Can someone help explain why I cannot change this option under the Default Config section for the scope. If I change the scope to anything else, I don't even see the option (which makes sense).

Config Scope

  • I've just upgraded to CE v2.1.6 and the issue is the same there. – Luke Cousins Apr 13 '17 at 11:59
  • Do you have any custom extensions that might touch the catalog module? I didn't find anything that might make the field disabled. – Marius Apr 18 '17 at 12:20
  • Thanks @Marius we have a few extensions installed, but none that I think should affect this. We have the BoostMyShop ERP and Infortis theme, but nothing else and I don't see how these should affect the catalog module. – Luke Cousins Apr 18 '17 at 12:25
1
+100

Check env.php for config setting overrides. I suspect you might have something like below in your env.php

'system' =>
    array(
        'default' =>
            array(
                'catalog' =>
                    array(
                        'price' =>
                            array(
                                'scope' => 0
                            )
                    )
            )
    )
  • Thanks, yes, this solved it. It was actually in app/etc/config.local.php and I could change the value there, or comment out the section completely and then make the changes within the admin panel. Really appreciate the help. Thanks again. – Luke Cousins Apr 21 '17 at 9:28
0

Do you have a staging site available? You can test if can change/add the value to the core_config_data table, that might solve it.

Also maybe this is caused by a third module. You can check all the modules via the command line with php bin/magento module:status and then disable all the third party modules with php bin/magento module:disable module_name and see if this solves your problem.

Both measures should be not be tried on live shops.

0

Check if Stores > Configuration > General > Single-Store Mode is set to Yes. If so change it to No.

  • 1
    I don't think this is it. When single store mode is enabled you cannot even see the product price scope dropdown. – Marius Apr 18 '17 at 12:16
  • Thanks, but @Marius is right, it is set to "No". – Luke Cousins Apr 18 '17 at 12:22
  • @Marius true but this was the only element I could find that changes something in this field. – Zefiryn Apr 18 '17 at 12:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.