Magento 1.9.3 - I cannot update because of plugins I am using.

-I have about 900 items on my website.

-17 of them in a Subcategory.

-The frontend shows that there are 17 items in the category - but only 5 shows on page 1 and 4 on page 2 (when sorted by 12 items per page. If I increase to 24 items per page, I see only the first 4.)

-If I disable all items and then re-enable all items, they show up briefly but then disappear again!

-Items are visible, enabled, in stock, in the correct category, added to the website.... Same settings as the other items on the page that all work fine.

I have been doing some searching some people are saying it has something to do with the Indexer? How do I fix it? Any ideas??


  • Is indexing working fine ? Commented Apr 12, 2017 at 15:00
  • Can you elaborate on that more? If I add new products, they show up... All the other categories seem to work fine. Just seems to be this one category... Commented Apr 12, 2017 at 15:47
  • based on your details, it looks like data issue. Commented Apr 12, 2017 at 15:53
  • How do I go about fixing it? www.WesternPetSupply.ca is my site - if that helps. The category in question is Dog/Toys Commented Apr 12, 2017 at 16:06

1 Answer 1


If you will see page source (HTML) of that category page.
You will find this <a href="http://www.westernpetsupply.ca/dog/toys/dogit-design-gumi-dental-dog-toy-chew-clean-large.html?___SID=U" title="Dogit Design Gumi Dental Dog Toy - Chew &amp; Clean - Large" class="product-image"><img src="<br /> <b>Fatal error</b>: Allowed memory size of 134217728 bytes exhausted (tried to allocate 18416 bytes) in <b>/home/overkill452/public_html/lib/Varien/Image/Adapter/Gd2.php</b> on line <b>74</b><br />
It is PHP memory issue on product "Dogit Design Gumi Dental Dog Toy", either upload a smaller filesize image or increase php memory_limit in .ini file to sort this issue.

  • Thanks! Increased the limit and it works! Turns out I was missing php5.ini... Copied my settings over and it's all good now. Thanks a bunch! :) Commented Apr 13, 2017 at 12:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.