3

The buttons are there, but as with 8788v2 patch they are showing on the left hand side, not the right, they are also not working. Checking in the console:

prototype.js:828 Uncaught ReferenceError: Uploader is not defined
    at eval (eval at <anonymous> (http://defibshop.yoma-cloud.co.uk/js/prototype/prototype.js:612:64), <anonymous>:3:24)
    at eval (eval at <anonymous> (http://defibshop.yoma-cloud.co.uk/js/prototype/prototype.js:612:64), <anonymous>:8:7)
    at http://defibshop.yoma-cloud.co.uk/js/prototype/prototype.js:612:64
    at http://defibshop.yoma-cloud.co.uk/js/prototype/prototype.js:865:29
    at http://defibshop.yoma-cloud.co.uk/js/prototype/prototype.js:825:18
    at Array.forEach (native)
    at Array.each (http://defibshop.yoma-cloud.co.uk/js/prototype/prototype.js:824:12)
    at Array.collect (http://defibshop.yoma-cloud.co.uk/js/prototype/prototype.js:864:10)
    at String.evalScripts (http://defibshop.yoma-cloud.co.uk/js/prototype/prototype.js:612:34)
    at Function.<anonymous> (http://defibshop.yoma-cloud.co.uk/js/prototype/prototype.js:391:23)

However I have copied the original file from the Magento version and replaced it, still not working. I have cleared the cache, reindexed and also tried a number of different browsers.

Any ideas what it could be?

8788 patch has been applied. In the console:

When loading the page, checking the console:

(index):1829 Uncaught ReferenceError: Uploader is not defined(anonymous function) @ (index):1829(anonymous function) @ (index):1834 (index):1846 Uncaught SyntaxError: Unexpected token ,

  • Have you applied SUPEE8788 ?? – Murtuza Zabuawala Apr 13 '17 at 5:06
  • Yes 8788 is applied, its a strange issue I must admit – Robert B Apr 13 '17 at 7:39
2

set js merged to no in System->Configuration->Developer

and

check below js were added or not

lib/uploader/flow.min.js
lib/uploader/fusty-flow.js
lib/uploader/fusty-flow-factory.js 
mage/adminhtml/uploader/instance.js

if those js were not included then include below js files in head and check

If those js file not present in directory then copy from the fresh magento and include this files via below code

<reference name="head">
        <action method="addJs"><file>lib/uploader/flow.min.js</file></action>
        <action method="addJs"><file>lib/uploader/fusty-flow.js</file></action>
        <action method="addJs"><file>lib/uploader/fusty-flow-factory.js</file></action>
        <action method="addJs"><file>mage/adminhtml/uploader/instance.js</file></action>
</reference> 
  • All those JS files are there and in the correct folders. set js merged to no in System->Configuration->Developer is already done. – Robert B Apr 13 '17 at 10:14
  • @RobertB please check that this files are loading in your page ?? – Murtuza Zabuawala Apr 13 '17 at 10:25
  • the files are not loaded in the network tab on inspect element – Robert B Apr 13 '17 at 10:44
  • @RobertB add this files in head via layout and your problem would solved – Murtuza Zabuawala Apr 13 '17 at 10:45
  • okay if I add it onto the local.xml that should work – Robert B Apr 13 '17 at 11:01
0

I had to add this into Main.xml

<action method="addJs"><file>lib/uploader/flow.min.js</file></action>
    <action method="addJs"><file>lib/uploader/fusty-flow.js</file></action>
    <action method="addJs"><file>lib/uploader/fusty-flow-factory.js</file></action>
    <action method="addJs"><file>mage/adminhtml/uploader/instance.js</file></action>
  • Can please specify where is located your Main.xml? – Mike Jun 23 '17 at 10:21
  • where the rest of the addJs entries are. – Robert B Jun 28 '17 at 9:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.