2

I have my web shop running and imported products above 50K. After import all categories pages taking longer time to load. e.g. 1 min. to 5 min. but before that the loading time was fair. Also, all the products are simple products type.

  1. Does Magento application cannot handle products above 50k effectively and its getting slower?
  2. Does I require to upgrade server infrastructure? Although, 5 GB memory is free out of 12 GB. It has 6 cores CPUs.
3
  • Sounds like the index doesn't keep up after importing so many products at once. Did you try to run a full reindex of your catalog and clear cache? – Niels Apr 12 '17 at 14:43
  • I forgot to mention, Re-Indexing was already performed. But thanks for your feedback. – user52945 Apr 13 '17 at 12:08
  • magento can handle even more products. we dont know how many products you load per page, also aoe_profiler debug is good to see – MagenX Apr 15 '17 at 9:39
1

Magento could be slow because of many reasons. You need to optimize the magento as well as MySQL for getting desired results.

1) Make sure you are using FLAT CATALOG. if you are not using it then enable it from System -> Configuration. This will speed up the catalog performance. Although, if your site is highly customized then enabling FLAT CATALOG would creates error many time so make sure you check your third party extension working properly after enabling it.

2) Disable Magento Logging if your site is in production environment.

3) Clear unwanted data from Magento database below is the list of all the tables.

SET foreign_key_checks = 0;
TRUNCATE dataflow_batch_export;
TRUNCATE dataflow_batch_import;
TRUNCATE log_customer;
TRUNCATE log_quote;
TRUNCATE log_summary;
TRUNCATE log_summary_type;
TRUNCATE log_url;
TRUNCATE log_url_info;
TRUNCATE log_visitor;
TRUNCATE log_visitor_info;
TRUNCATE log_visitor_online;
TRUNCATE report_viewed_product_index;
TRUNCATE report_compared_product_index;
TRUNCATE report_event;
TRUNCATE index_event;
TRUNCATE catalog_compare_item;
SET foreign_key_checks = 1;

4) Compress and minify CSS and JS, compress it using Gzip and enable browser caching for static content like CSS, JS, Images.

5) Make sure you have optimized MySQL with Query Caching, buffer, IO READ/ Write etc.

6) Apache/Nginx should be well optimized with php-cgi to handle Magento Request.

7) You can also implement tools like Redis , Memcached or varnish etc for better performance.

Hope this would help you achieve your goal.

2
  • Thank you Yagnesh, most of the steps you listed were success. – user52945 Apr 14 '17 at 12:41
  • im afraid nothing from this list will help with this issue... probably his category pages are overloaded (some shoppers load too many products at once) or even aoe_profiler needs to be executed to check whats going on there. – MagenX Apr 15 '17 at 9:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy