4

I have been trying to disable JQMIGRATE but everything I have tried has not worked. I have followed the instructions present within the jquery folder in Magento 2.

But its still showing as Active. I have in Magento

  • Reindex
  • Cache
  • Static:content:deploy

But its not disabled. Could this be a browser or Magento issue.

2

2 Answers 2

5

I followed kind of like the same path as @thaddeusmt but I only added things at a custom requirejs-config.js file:

require(['jquery'], function(jQuery) {
    jQuery.migrateMute = true;
});

var config = {};
2
  • This seems the least intrusive or destructive method. Too bad the init shim doesn't work on loading jquery, because that would be the ideal solution Commented Sep 26, 2019 at 10:09
  • Many thanks for this Jisse
    – diazwatson
    Commented Sep 6, 2020 at 23:33
0

I ended up overriding the core jquery-migrate in our theme so I could set the migrateMute option.

In my theme require-jsconfig.js I set this override:

var config = {
  paths: {
    // disable jQuery migrate console output
    'jquery/jquery-migrate': 'js/jquery-migrate'
  }
}

Then copied the code jquery-migrate.js file to the theme js directory, and added this line towards the top:

// Set to true to prevent console output; migrateWarnings still maintained
jQuery.migrateMute = true;
2
  • We are also seeingthis in M2.3.1. : is this still the proposed solution? (vanilla install)
    – snh_nl
    Commented Apr 23, 2019 at 7:05
  • @thaddeusmt, by doing this, Jqmigrate will remove from the site or it just not visible in the console
    – Siva
    Commented May 29, 2019 at 11:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.