0

I have set host value to use a remote IP in my env.php file. But I got an error saying "Access denied for user 'manager'@'localhost'(using password: YES)"

why Magento 2 still says I'm using the localhost?

I have tested the username and password for mysql, so I'm sure they are correct. And the mysql user I used have remote access

I have cleared the Cache, di, generation folder.

0

It already happened here, maybe your database doesn't have permit to this user, to check use this command below changing the user (-u parameter), password (-p parameter), host (-h parameter) and database (-D parameter):

mysql -uroot -proot -h 127.0.0.1 -D database

If it doesn't work, try access with your root user to check.

  • Sorry, i edited my comments. your command works find for me if I use root. But when if I use root login in env.php. it still give me the same error. – Magento Learner Apr 10 '17 at 14:47
  • Try to update your Magento to 2.0.13 – Rafael Corrêa Gomes Apr 10 '17 at 14:52
  • I'm already using 2.1.0 – Magento Learner Apr 10 '17 at 15:08
  • So update to 2.1.15 – Rafael Corrêa Gomes Apr 10 '17 at 16:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.