0

So I know this used to be a common problem in M1.x. However, I only recently noticed this in our M2.1.3 environment.

Notice the Processing date

How can I flush/wipe the Category flat data index and rebuild from scratch?

  • If its not production then try to truncate (take a backup before doing so) the category flat table and start the indexing again. – Kingshuk Deb Apr 7 '17 at 18:29
  • This is happening in a production environment. However, I can put it in maintenance mode on a slow moment, and do it then. – Spyrule Apr 7 '17 at 23:01
0

It normally happens when the memory limit is few, so increase on your .htaccess or NGINX config.

Run this command on your MySQL:

update indexer_state set status = 'invalid' where status != 'valid';

On you terminal run:

alias mage="php -d memory_limit=-1 -f bin/magento"
mage indexer:reindex
  • my php is set to 2GB of memory usage. – Spyrule Apr 7 '17 at 23:00
  • @Spyrule check your cron too – Rafael Corrêa Gomes Apr 8 '17 at 4:14
0

You can also check mview_state table and set status to idle on that indexer then run it from cli with

php bin/magento indexer:reindex catalog_category_flat

If it break you should see some stack trace in the console

  • So interestingly enough, they are all idle, however they are all, also set to disable for mode. Which is odd. – Spyrule Apr 7 '17 at 23:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.