2

I have enabled Free Shipping Method and Fedex in Magento 2 but during checkout I get an error as shown below -

enter image description here

What might be the issue ?

  • Are you using any extension for shipping method? – mageDev0688 Apr 6 '17 at 5:51
  • No just the default Fedex method. – Piyush Dangre Apr 6 '17 at 6:31
4

you need to add code to this one file.

pub/static/frontend/magento/theme/en_US/Magento_Checkout/js/view/billing-address.js

addressOptions.push(newAddressOption);

       // start adding fix
       if (_.isEmpty(countryData())) {
    countryData(customerData.reload(['directory-data'], false));
       }
       // end adding fix

return Component.extend({

you need to copy code in your Magento_Checkout/js/view/billing-address.js extension file in also so once you deploy it will not delete.

  • This worked for us. Thanks, how on earth did you uncover this bug!? – Adam Lavery Mar 23 '18 at 8:46
  • 1
    It's my job to recognize issues. – Magento2 Devloper Mar 23 '18 at 9:55
  • I have changed in this billing-address.js file, but I cannot see the change in the browser. I have tried every option. Can you please tell me what more to do to see the change? – JN_newbie Apr 20 '18 at 11:06
  • For anyone else, if the fix doesn't work patching the theme static files, try patching the core file and re-deploying the static files. If that still doesn't fix it, ensure all caches, including browser are cleared and log the customer account out/in. – Adam Lavery Jun 26 '18 at 8:42
1

I figured out that the web services url was blocked in my office. I went home and carried out the process from different network and Voila ! It worked smoothly.

0

You need to select state for US. Each shipping method registers fields which change may mean it is available/unavailable and default ones are listening on country, region_id/region and postcode. Changing one of it tries to refresh shipping methods but in order to do that all observerd fields need to be valid. Since region_id is required for US no refresh on shipping methods is done.

  • Even after selecting state, city, zipcode for US the error remains same. Can you help me out with this? – Piyush Dangre Apr 6 '17 at 6:34
  • Any errors in the console? – Zefiryn Apr 6 '17 at 20:53
  • I figured out that the web services url was blocked in my office. Thanks ! – Piyush Dangre Apr 7 '17 at 6:19
0

I spent a little time on this issue and found that the PHP Soap extension was not installed. Check your developer console and requests to estimate-shipping-methods to see if there is an error upon input changes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.