Here is the pic the showing the tinyMCE is not showing and the button is not work

enter image description here

The browser console does not have any exception or error is showing, anyone know what is the problem?

Remarks tested on (xampp+windows and nginx+php7)

  • I had this problem recently in Firefox. Switching to chrome solved it. Commented Apr 6, 2017 at 16:10

4 Answers 4


this is a known Magento js bug, there is a fix for it but not deployed in the current version so you would need to patch Magento:

  1. the fix url is: https://github.com/magento/magento2/commit/3524943ac6544ee969480536ef6f0cd1a29b0b56.patch ( just the github issue sollution with .patch extension added ) save the content of the patch into a file ex: vendor_patches/MAGETWO-57675-Base.diff in the root of magento where vendor_patches is an directory created for patches

  2. and you can create a patch as follows: Add to your composer.json ( in the root of magento )


    "require": {
        "cweagans/composer-patches": "~1.4.0",
    "extra": {
        "patches": {
            ""magento/magento2-base": {
                "[PATCH] MAGETWO-57675: [GITHUB] WYSIWYG editor does not show. #6222": "vendor_patches/MAGETWO-57675-Base.diff"


  3. Run composer update in the root of your magento

  • this work for me , thx
    – hkguile
    Commented Apr 12, 2017 at 9:35

Check on this configuration:

Store > Configuration > General > Content Management > Enable wysiwyg.

But if is enabled it is taking time to load, but I do this to optimize and to load normally:

  • Increase the memory_limit and max_execution_time on .htaccess or NGINX config.
  • If don't is developing, enable the cache.
  • Run the deploy of the static files again.
  • Give permit to folders var/ and pub/static.
  • But because of the Knockout, I wait to load this feature.
  • When JS Bundling and CSS minification are enabled. I have the issue where it does not display. However, I get a bunch of JS errors of Failed to load: /themes/advanced/editor_template.js, /back/edit//langs/en.js and 50 or so similiar ones. Do you have any thoughts?
    – Rob
    Commented May 7, 2018 at 13:23

Solution worked in my case:

Store > Configuration > General > Content Management > WYSIWYG Editor Select tinymce 3 (deprected)

  1. Go to store->configuration→general→content management→enable wysiwyg edit uncheck checkbox and save configurations.
  2. Remove pub/static ,var/generation ,var/cache,var/view_preprocessed
  3. deploy static content
  • if you work on the development enviornment it is not a sollution to deploy static content since you work with symlinks
    – Vlad Patru
    Commented Apr 6, 2017 at 16:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.