0

I am trying to install Magento 2.1.5 and I'm currently stuck on the readiness check. It is currently giving this error

PHP Settings Check * Need Help? PHP Documentation Your PHP Version is 5.6.30, but always_populate_raw_post_data = 0. $HTTP_RAW_POST_DATA is deprecated from PHP 5.6 onwards and will be removed in PHP 7.0. This will stop the installer from running. Please open your php.ini file and set always_populate_raw_post_data to -1. If you need more help please call your hosting provider.

I have renamed the php.ini file and have included the stipulated line and still have no luck. My ini file is as follows:

; Copyright © 2013-2017 Magento, Inc. All rights reserved.
; See COPYING.txt for license details.
; This file is for CGI/FastCGI installations.
; Try copying it to php5.ini, if it doesn't work

memory_limit = 1024M
max_execution_time = 18000

; disable automatic session start
; before autoload was initialized

flag session.auto_start = off
always_populate_raw_post_data = -1
; enable resulting html compression

zlib.output_compression = on

; disable user agent verification to not break multiple image upload

suhosin.session.cryptua = off

; PHP for some reason ignores this setting in system php.ini
; and disables mcrypt if this line is missing in local php.ini

extension=mcrypt.so

; Disable PHP errors, notices and warnings output in production mode to prevent exposing sensitive information.

display_errors = Off
0

You need to make sure this line is in your PHP.ini file. Edit your PHP.ini file and add it in:

always_populate_raw_post_data = -1

To check it has worked, run PHP on the command line and search for the setting:

php -i | grep always_populate_raw_post_data

You should find the setting now appears as -1:

always_populate_raw_post_data => -1

You should now be able to get past this error message.

Good luck.

0

Just seen the necessary line lurking in your .ini file, however it looks like you're missing a semicolon (';') or new line after:

flag session.auto_start = off  

In fact the whole block looks wrong! The 'flag' keyword looks out of place.

0

Open your php.ini file and find always_populate_raw_post_data, set it to always_populate_raw_post_data = -1. Save php.ini & Restart your web server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.