1

Ever since moving our Magento store to a new server we have been having strange issues with the store.

Currently the store appears to work correctly but once an item is added to the cart all the pages break. The only part that loads is the header.

View the issue here by adding any item to the cart: http://xpresselectrical.ie

There hasn't been any changes to the code base since moving to the new server so I must assume there is something different about this servers configuration.

I have enabled ini_set('display_errors', 1); in index.php but no errors are shown.

Does anybody know what would cause this issue or how it can be resolved?

Thanks.

6
  • Looks fine to me. I added a product to the cart and everything is OK.
    – Marius
    Commented Mar 12, 2014 at 10:56
  • Not for me, only header loaded on add to cart. (Firefox/IE 11) Have you checked your system.log and exception.log file in /var/log?
    – SR_Magento
    Commented Mar 12, 2014 at 10:56
  • Ah...I found one product that breaks the page. The page rendering stops at the cart header with <img scr=". Check the template that is rendering the minicart and see if there is a problem with the image display.
    – Marius
    Commented Mar 12, 2014 at 10:59
  • Thanks for the replies guys. I have discovered that our new server does not have the GD Library extension installed! This would probably explain why the page rendering stops at the img tag. I am currently updating our Apache configuration and installing GD. Hopefully that will solve the issue.
    – dekin88
    Commented Mar 12, 2014 at 11:21
  • @Marius, please post it as an answer so topic starter can accept it. Commented Mar 12, 2014 at 11:22

1 Answer 1

1

The page rendering stops at the cart header with <img src=". Check the template that is rendering the minicart and see if there is a problem with the image display.


Added as an answer at @Tim's suggestion

1
  • Decided to do a few other bits since the website was down anyway. That seems to have solved our problem anyway, pages are loading properly and everything looks good. Thanks.
    – dekin88
    Commented Mar 12, 2014 at 14:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.