0

Whenever I try to upload a large, I get this:

You probably tried to upload a file that is too large. Please refer to documentation for a workaround for this limit.

Is there by chance a way to change this? I've google it but nothing found (unless about old versions old xampp).

  • Did you try cmd prompt upload(you are asking local machine right) – Magento 2 Mar 25 '17 at 21:35
  • No, I didn't. Could you please tell me the codes? – RyckRichards Mar 25 '17 at 22:48
1

Via SSH CLI

Typically you want to SCP (secure copy) the SQL file to the server and run the mysql client to import the SQL script.

To send the file to the server, one would use this command:

scp dump.sql username@my-server.com:

Then you would SSH to my-server.com and run the following command to import your database:

mysql my_database < /path/to/dump.sql

mysql is the MySQL CLI client application (For Debian/Ubuntu: sudo apt-get install mysql-client)

my_database is the name of the database you want to import into

/path/to/dump.sql is the file path to the SQL dump file


Alternative via GUI Application

If you have a user account that can access from anywhere, you could use MySQL Workbench ( https://www.mysql.com/products/workbench/ ) to do the import through a GUI application.

  • 1st part ok but 2nd part... USER@USER-PC c:\xampp # mysql tatoeba_database.sql < C:\xampp\mysql\data\tatoeba Access is denied. USER@USER-PC c:\xampp # mysql -u root tatoeba_database.sql < C:\xampp\mysql\data\tatoeba; Access is denied. USER@USER-PC c:\xampp # mysql tatoeba_database.sql < C:\xampp\mysql\data\tatoeba; Access is denied. USER@USER-PC c:\xampp – RyckRichards Mar 26 '17 at 1:21
  • If you're using Windows, and it's on your local machine, just install MySQL Workbench and use it to do the import. Install it, connect to the database server with it, and then there is an import option. – Brett Mar 26 '17 at 1:25
  • Oh, perfect! Thanks a lot for that! I've just download. mysql-installer-community-5.7.17.0 – RyckRichards Mar 26 '17 at 1:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.