0

After doing a fresh installation of Magento 2.0.12. I am getting "whoops, our bad" page for all pages except the homepage(index). The homepage load fine but for all other pages/links , I m getting this 404 error.

I tried adding Rewritebase / in the .htaccess, but it didn't change anything.

Can please someone help. Here's is how the values in .htaccess looks like.


DirectoryIndex index.php php_value memory_limit 768M php_value max_execution_time 18000 php_flag session.auto_start off php_flag suhosin.session.cryptua off php_value memory_limit 768M php_value max_execution_time 18000 php_flag session.auto_start off php_flag suhosin.session.cryptua off SecFilterEngine Off SecFilterScanPOST Off SSLOptions StdEnvVars RewriteBase / Options +FollowSymLinks RewriteEngine on RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}] RewriteCond %{REQUEST_METHOD} ^TRAC[EK] RewriteRule .* - [L,R=405] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_FILENAME} !-l RewriteRule .* index.php [L] AddDefaultCharset Off AddType 'text/html; charset=UTF-8' html ExpiresDefault "access plus 1 year" ExpiresByType text/html A0 ExpiresByType text/plain A0 RedirectMatch 403 /.git order allow,deny deny from all order allow,deny deny from all order allow,deny deny from all order allow,deny deny from all order allow,deny deny from all order allow,deny deny from all order allow,deny deny from all order allow,deny deny from all order allow,deny deny from all order allow,deny deny from all order allow,deny deny from all order allow,deny deny from all order allow,deny deny from all order allow,deny deny from all order allow,deny deny from all order allow,deny deny from all order allow,deny deny from all order allow,deny deny from all ErrorDocument 404 /pub/errors/404.php ErrorDocument 403 /pub/errors/404.php Header set X-UA-Compatible "IE=edge" Header unset X-UA-Compatible

0

Please ensure that you have enabled mod_rewrite apache module. After enabling it, restart apache server.

In ubuntu, you can do as per following steps.

sudo a2enmod rewrite

This will activate the module or alert you that the module is already in effect. To put these changes into effect, restart Apache.

sudo service apache2 restart
  • I already have mod_write enabled and also AllowOverride set to All. What else could be causing it? – Pawan Monga Mar 26 '17 at 15:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.