0

I am facing problem while translating text, I have two stores views, English and French. On French store view the text is translated with special characters. ex:

Qty = Qté
Recently added item(s) = Derniers articles ajoutés.

It need to display "Qté" and "Derniers articles ajoutés" respectively. I have added all the translation words in:

app\design\frontend\THEME\default\locale\fr_FR\translate.csv

But no success. I don't want to translate this with inline translation functionality.

Why is this happening any idea?

1

This is the utf-8 encoding problem !

You have wrong encoding either in your IDE, database or in documents translation files. Ensure that the encoding is utf-8 in :

IDE while editing: choose the utf-8 encoding

Database: -> app/etc/local.xml <initStatements><![CDATA[SET NAMES utf8]]></initStatements>or <charset>utf8</charset>

Database should looks like:

        <default_setup>
            <connection>
                <host><![CDATA[localhost]]></host>
                <username><![CDATA[db_user_name]]></username>
                <password><![CDATA[db_password]]></password>
                <dbname><![CDATA[db_name]]></dbname>
                <initStatements><![CDATA[SET NAMES utf8]]></initStatements> //<---
                <model><![CDATA[mysql4]]></model>
                <type><![CDATA[pdo_mysql]]></type>
                <pdoType><![CDATA[]]></pdoType>
                <active>1</active>
                <charset>utf8</charset> //<---
            </connection>
        </default_setup>
| improve this answer | |
  • I changed my sublime text IDE to with UTF-8 encoding and saved my files again. but no use its still showing same characters. Is there any other settings related Magento db? – Charlie Mar 26 '17 at 3:43
  • Look my updates please – PЯINCƏ Mar 26 '17 at 8:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.