0

well there is an issue with newsletter in magento 2.is i have created newsletter template for subscriber but when i set a date and time to it.it was still not going to my subscribers.apart from this Transnational Emails are going perfectly only newsletter email are not going.also time is scheduling 4 hours latter while setting newsletter queue timings enter image description here.

  • any suggestions for the same? – Yogesh Raghav Mar 25 '17 at 9:14
  • any reply for the same please? – Yogesh Raghav Apr 28 '17 at 5:16
0

Here's how:

  1. Choose correct timezone to solve timing issue as follow.

    Stores-> Configuration -> General -> General -> Locale Options -> Timezone

  2. You have to set Cronjob to send newsletter automatically on scheduled time. or you can manually run this command to run cron manually:

    php bin/magento cron:run

For more details please visit below link:

How to Setup Cron Job Magento 2 - Schedule Tasks

Note: I had to install SMTP extension (https://www.mageplaza.com/magento-2-smtp/) to send emails from my localhost.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.