0

It shows blank page when navigating to System -> Configuration as shown in below image-

enter image description here

and after changing in 'current configuration scope' dropdown to any website view or store view it shows 404 error on the page like below.

enter image description here

I don't know why it's happening, may be any module is cause of this or anything else ?

Please suggest.

Thanks

1
  • 2
    Debug-Hint : Disable module one by one and check which module is cause for this error. After finding that module check config.xml file <acl></acl> tag and check system.xml file and validate it with other module Commented Mar 24, 2017 at 8:43

2 Answers 2

1

This is because some extension you installed lately is incorrectly overriding admin layout/routes.

I had the same issue with "extended google sitemap" extension. Admin was showing 404 if click "System > Configuration" dropdown menu.

You see "save config" yellow button in the top right corner? Look in sources/or click it, it will show you where is the issue. (see headers or network tab in browser developers tools)

Also make sure your account have full ACL access rights to every page and module.

3
  • Thanks MagenX, I have used Ultimate SEO module that uses default Google Sitemap, but as there is Extended Google sitemap extension enabled so it overwrite the default Google Sitemap , thats why it causes error. Commented Mar 24, 2017 at 10:31
  • Can you know How can I set a page as default page for System>Configuration>Index page ? Commented Mar 24, 2017 at 10:31
  • report the issue to extension developer
    – MagenX
    Commented Mar 24, 2017 at 11:02
0

1) Clear magento cache.

2) Logout from admin panel and login again.

6
  • Thank for reply still it doesn't work. Commented Mar 24, 2017 at 7:20
  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. - From Review Commented Mar 24, 2017 at 8:38
  • 2
    @vaibhavahalpara in some case this could be answer. Commented Mar 24, 2017 at 8:50
  • I don't know that much about but i think this solution works for 404 error only not for blank page Commented Mar 24, 2017 at 8:56
  • @vaibhavahalpara This could be wrong answer but this is not comment Commented Mar 24, 2017 at 9:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.