0

We've recently migrated the whole magento webshop to the https structure.

There comes the issue: The product pages are still unsecure, because each product logo is loaded from an unsecure source. Here is the Google Inspector insight:

Mixed Content: The page at 'product-page-url' was loaded over HTTPS, but requested an insecure image 'http://www.safegear.dk/media/brand/birkegaarden.gif'. This content should also be served over HTTPS.

The logo that is loaded over http is the one of "Birkegaarden", in the top right (see image)product_page

Thanks to everyone who will be taking a minute to read these few lines!

Enrico

0

Select Current Configuration Scope and go to Advanced > Developer > Template Path Hints and turn this on to find where the template is that is controlling the brand logo.

then change the URL structure so it is similar to this:

<img src="{{media url='wysiwyg/brands/image.jpg' _secure="true" }}"

Or just add https or remove http:

  • That´s GREAT!Thank you so much @Mike Tim Turner !!I totally solved the problem! I would add that a store view should be selected before finding the "Template Path Hints" option...it is not showing in Default view. – Enrico Piazza Mar 23 '17 at 12:51
  • Updated my answer :) – Mike Tim Turner Mar 23 '17 at 13:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.