0

Composer version is 1.4.1

I ran composer require magento/project-community-edition 2.1.4 --no-update and then composer update

Error message returned: Your requirements could not be resolved to an installable set of packages. The requested package magento/project-community-edition 2.1.2 is satisfiable by magento/project-community-edition[2.1.2] but these conflict with your requirements or minimum-stability.

My composer.json:

{
    "name": "magento/project-community-edition",
    "description": "eCommerce Platform for Growth (Community Edition)",
    "type": "project",
    "version": "2.1.2",
    "license": [
        "OSL-3.0",
        "AFL-3.0"
    ],
    "require": {
        "composer/composer": "@alpha",
        "magento-hackathon/magento-composer-installer": "3.0.*",
        "magento/project-community-edition": "2.1.4"
    },
    "require-dev": {
        "phpunit/phpunit": "4.1.0",
        "squizlabs/php_codesniffer": "1.5.3",
        "phpmd/phpmd": "@stable",
        "pdepend/pdepend": "2.2.2",
        "fabpot/php-cs-fixer": "~1.2",
        "lusitanian/oauth": "~0.3 <=0.7.0",
        "sebastian/phpcpd": "2.0.0"
    },
    "config": {
        "use-include-path": true
    },
    "autoload": {
        "psr-4": {
            "Magento\\Framework\\": "lib/internal/Magento/Framework/",
            "Magento\\Setup\\": "setup/src/Magento/Setup/",
            "Magento\\": "app/code/Magento/"
        },
        "psr-0": {
            "": "app/code/"
        },
        "files": [
            "app/etc/NonComposerComponentRegistration.php"
        ]
    },
    "autoload-dev": {
        "psr-4": {
            "Magento\\Sniffs\\": "dev/tests/static/framework/Magento/Sniffs/",
            "Magento\\Tools\\": "dev/tools/Magento/Tools/",
            "Magento\\Tools\\Sanity\\": "dev/build/publication/sanity/Magento/Tools/Sanity/",
            "Magento\\TestFramework\\Inspection\\": "dev/tests/static/framework/Magento/TestFramework/Inspection/",
            "Magento\\TestFramework\\Utility\\": "dev/tests/static/framework/Magento/TestFramework/Utility/"
        }
    },
    "minimum-stability": "alpha",
    "prefer-stable": true,
    "repositories": [
        {
            "type": "composer",
            "url": "https://repo.magento.com/"
        }
    ],
    "extra": {
        "magento-force": "override"
    }
}

Installed CE 2.1.2 via Composer. How do I upgrade?

2
  • In your composer.json you set "name" to "magento/project-community-edition" and its version is 2.1.2. Maybe try setting that version to 2.1.4 also. (Or change your package name to something other than "magento/project-community-edition")
    – user50408
    Mar 22, 2017 at 5:43
  • @dmatthew I changed the version to 2.1.4 and ran "composer update". Composer then deleted the core dependencies (zendframework, colinmollenhour, magento, monolog, braintree, phpseclib, league, tedivm, tubalmartin, etc) under the vendor directory. It installed & updated symfony, justinrainbow, and composer.
    – Leo Tse
    Mar 22, 2017 at 20:17

1 Answer 1

2

I have found the solution from the answer of this question.

It seems upgrading to 2.1.4 from 2.1.2 is not possible. I tried the same upgrading procedure with 2.1.5, and it worked.

composer require magento/product-community-edition 2.1.5 --no-update

composer update

rm -rf var/di var/generation

php bin/magento cache:clean

php bin/magento cache:flush

php bin/magento setup:upgrade

php bin/magento setup:di:compile

php bin/magento indexer:reindex

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.