0

I've never asked a question here before (probably obvious). This has turned into a bit of a wall of text but I want to give as much information as possible. I'm currently fumbling my way through being in charge of a Magento store. I think it's running either 1.7 or 1.8, I can't remember off the top of my head and I can't login to the backend to check! Anyway, I've looked through all the other posts about this kind of error but I couldn't find anything I felt like I understood well enough to try. Full disclosure, I'm not a web developer or anything, I'm just trying to solve this problem because we don't have anyone else to do it.

This error comes up when I try to login to the backend. I've only seen it today, but it might have occurred over the weekend as well. I haven't touched any of the code, actually haven't done anything at all to the website in the past week. It seemed to be working fine last Monday. The store itself has been running for 2 years with only a couple of hiccups, nothing like this before. The frontend seems to be working fine. It'll let me fill out the login screen, but upon entering my details it just loads a blank screen with the URL /index.php/admin. When I refresh I am redirected to one of the generic 'There has been an error processing your request'. I've tried clearing my cookies and it didn't make a difference.

The most recent error message in var/reports is as follows:

a:5:{i:0;s:123:"Cannot send headers; headers already sent in /home2/luathpre/public_html/luathpress/lib/Zend/Acl/Role/Interface.php, line 1";i:1;s:1489:"#0 /home2/luathpre/public_html/luathpress/lib/Zend/Controller/Response/Abstract.php(148): Zend_Controller_Response_Abstract->canSendHeaders(true)
(#)1 /home2/luathpre/public_html/luathpress/app/code/core/Mage/Core/Controller/Response/Http.php(106): Zend_Controller_Response_Abstract->setRedirect('https://www.lua...', 302)
(#)2 /home2/luathpre/public_html/luathpress/app/code/core/Mage/Adminhtml/Controller/Action.php(348): Mage_Core_Controller_Response_Http->setRedirect('https://www.lua...')
(#)3 /home2/luathpre/public_html/luathpress/app/code/core/Mage/Adminhtml/Controller/Action.php(182): Mage_Adminhtml_Controller_Action->_redirect(Object(Varien_Simplexml_Element))
(#)4 /home2/luathpre/public_html/luathpress/app/code/core/Mage/Core/Controller/Varien/Action.php(407): Mage_Adminhtml_Controller_Action->preDispatch()
(#)5 /home2/luathpre/public_html/luathpress/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(254): Mage_Core_Controller_Varien_Action->dispatch('index')
(#)6 /home2/luathpre/public_html/luathpress/app/code/core/Mage/Core/Controller/Varien/Front.php(172): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
(#)7 /home2/luathpre/public_html/luathpress/app/code/core/Mage/Core/Model/App.php(354): Mage_Core_Controller_Varien_Front->dispatch()
(#)8 /home2/luathpre/public_html/luathpress/app/Mage.php(685): Mage_Core_Model_App->run(Array)
(#)9 /home2/luathpre/public_html/luathpress/index.php(92): Mage::run('', 'store')
(#)10 {main}";s:3:"url";s:16:"/index.php/admin";s:11:"script_name";s:10:"/index.php";s:4:"skin";s:5:"admin";}

I've seen a few posts saying that this is to do with a blank space in front of the php tag in the named file. Trouble is, over the course of today it's generated at least 200 of these reports, and from what I can tell they're all slightly different. I can't see how all of these files could suddenly have an error in them, when they were fine last week.

I'll include a couple of others, just to demonstrate:

a:5:{i:0;s:123:"Cannot send headers; headers already sent in /home2/luathpre/public_html/luathpress/lib/Zend/Acl/Role/Interface.php, line 1";i:1;s:1489:"#0 /home2/luathpre/public_html/luathpress/lib/Zend/Controller/Response/Abstract.php(148): Zend_Controller_Response_Abstract->canSendHeaders(true)
#1 /home2/luathpre/public_html/luathpress/app/code/core/Mage/Core/Controller/Response/Http.php(106): Zend_Controller_Response_Abstract->setRedirect('https://www.lua...', 302)
#2 /home2/luathpre/public_html/luathpress/app/code/core/Mage/Adminhtml/Controller/Action.php(348): Mage_Core_Controller_Response_Http->setRedirect('https://www.lua...')
#3 /home2/luathpre/public_html/luathpress/app/code/core/Mage/Adminhtml/Controller/Action.php(182): Mage_Adminhtml_Controller_Action->_redirect(Object(Varien_Simplexml_Element))
#4 /home2/luathpre/public_html/luathpress/app/code/core/Mage/Core/Controller/Varien/Action.php(407): Mage_Adminhtml_Controller_Action->preDispatch()
#5 /home2/luathpre/public_html/luathpress/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(254): Mage_Core_Controller_Varien_Action->dispatch('index')
#6 /home2/luathpre/public_html/luathpress/app/code/core/Mage/Core/Controller/Varien/Front.php(172): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#7 /home2/luathpre/public_html/luathpress/app/code/core/Mage/Core/Model/App.php(354): Mage_Core_Controller_Varien_Front->dispatch()
#8 /home2/luathpre/public_html/luathpress/app/Mage.php(685): Mage_Core_Model_App->run(Array)
#9 /home2/luathpre/public_html/luathpress/index.php(92): Mage::run('', 'store')
#10 {main}";s:3:"url";s:16:"/index.php/admin";s:11:"script_name";s:10:"/index.php";s:4:"skin";s:5:"admin";}

a:5:{i:0;s:117:"Cannot send headers; headers already sent in /home2/luathpre/public_html/luathpress/lib/Varien/Cache/Core.php, line 1";i:1;s:1117:"#0 /home2/luathpre/public_html/luathpress/lib/Zend/Controller/Response/Abstract.php(115): Zend_Controller_Response_Abstract->canSendHeaders(true)
#1 /home2/luathpre/public_html/luathpress/app/code/core/Mage/Core/Model/App.php(1246): Zend_Controller_Response_Abstract->setHeader('Content-Type', 'text/html; char...')
#2 /home2/luathpre/public_html/luathpress/app/code/core/Mage/Core/Controller/Varien/Front.php(80): Mage_Core_Model_App->getResponse()
#3 /home2/luathpre/public_html/luathpress/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(202): Mage_Core_Controller_Varien_Front->getResponse()
#4 /home2/luathpre/public_html/luathpress/app/code/core/Mage/Core/Controller/Varien/Front.php(172): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#5 /home2/luathpre/public_html/luathpress/app/code/core/Mage/Core/Model/App.php(354): Mage_Core_Controller_Varien_Front->dispatch()
#6 /home2/luathpre/public_html/luathpress/app/Mage.php(685): Mage_Core_Model_App->run(Array)
#7 /home2/luathpre/public_html/luathpress/index.php(92): Mage::run('', 'store')
#8 {main}";s:3:"url";s:152:"/catalogsearch/result/?q=%22Susan+Bennett+%28ed.%29%2C+Mary+Byatt+%28ed.%29%2C+Jenny+Main+%28ed.%29%2C+Anne+Oliver+%28ed.%29+Janet+Trythall+%28ed.%29%22";s:11:"script_name";s:10:"/index.php";s:4:"skin";s:7:"default";}

If anybody has any suggestions as to what I should try, I'd be very grateful. I'm happy to provide more information and do troubleshooting. (Also, if the answer is "Hire a professional!" I'll take that to my boss, but I'm going to have to be able to say I've tried everything I can do first.)

I have to go home now but I'll be back tomorrow morning to check on this. Thanks for reading!

1

Please enable developer mode for your magento.

For this do below things:

go to your magento root directory and check index.php file and do some changes. Write below code above #ini_set('display_errors', 1);

Mage::setIsDeveloperMode(true);

and then remove "#" from init_set('display_errors',1);

After doing this just clear your cache and then you will be able to see exact errors on your browser. Then put those errors here.

To disable developer mode, you have to do Mage::setIsDeveloperMode(false); and put # again before init_set('display_errors',1);

  • Thanks so much for responding! Okay, so this is interesting. I'm not sure that it's what you expected to happen, though. I followed your instructions about an hour ago, and was surprised to discover that rather than seeing errors I could log in and use the backend as normal! I turned Developer mode off again, and it carried on working until a few minutes ago, when I ran into the same error as before. I turned Developer mode back on again, cleared the cache, and now I once again have access. So, no errors to post. Thanks again! – Jules Mar 21 '17 at 11:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.