0

I use MAGMI to import and manage inventory of products in magento 1.9.3. Many items show in_stock and qty > 0 in admin but display as out of stock on the front end, saving the product on the admin site seems to fix the issue, but it's not reasonable to re-save full catalog as it's quite large. The products are visible on the front end and in the right category.

Please help!

0

For this turn on Magmi "On the fly indexer" plugin and check all the fields in csv file are having correct values. This seems to be indexing issue. Please clear all related cache and index and check all the fields in csv file for proper values because magmi has it's own fields values and settings. for e.g. for visibility it takes value from 1 to 4(1->not visible individually, 4->visible in catalog,search). so Double check for fields and their values. try to take fields and values from default files provided by magmi.

  • Indexer is enabled and column values look OK. I'll take other suggestions. – Eugene Lorman Mar 20 '17 at 19:45
  • Also if your inventory shows perfect in backend and not resembling in frontend i will advise you to clear cache. Sometimes magento don't clear cache from backend you have to go inside 'var/cache/' to delete the cache manually. So try to delete cache from var folder manually. – RUSHABH SHAH Mar 29 '17 at 10:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.