0

When I add /api/v2_soap?wsdl=1 to the url I get:

This page isn’t working

local.example.en is currently unable to handle this request.
HTTP ERROR 500

With dev mode and error messages enabled I get this instead:

Fatal error: Maximum execution time of 30 seconds exceeded in /var/www/public/app/code/core/Mage/Api/Model/Wsdl/Config/Element.php on line 235

But /api/soap/?wsdl works fine.

WS-I Compliance is set to "Yes" in Magento backend.

exception.log has this message (Ebizmarts/SagePaySuite is not my module):

exception 'Exception' with message 'String could not be parsed as XML' in /var/www/public/app/code/local/Ebizmarts/SagePaySuite/Model/Feed/Updates.php:35
Stack trace:
#0 /var/www/public/app/code/local/Ebizmarts/SagePaySuite/Model/Feed/Updates.php(35): SimpleXMLElement->__construct('<html>??<head><...')
#1 /var/www/public/app/code/local/Ebizmarts/SagePaySuite/Model/Feed/Updates.php(101): Ebizmarts_SagePaySuite_Model_Feed_Updates->getFeedData('http://store.eb...')
#2 /var/www/public/app/code/local/Ebizmarts/SagePaySuite/Model/Feed/Updates.php(90): Ebizmarts_SagePaySuite_Model_Feed_Updates->_getUpdates('Ebizmarts_SageP...')
#3 /var/www/public/app/code/core/Mage/Core/Model/App.php(1339): Ebizmarts_SagePaySuite_Model_Feed_Updates->check(Object(Varien_Event_Observer))
#4 /var/www/public/app/code/core/Mage/Core/Model/App.php(1312): Mage_Core_Model_App->_callObserverMethod(Object(Ebizmarts_SagePaySuite_Model_Feed_Updates), 'check', Object(Varien_Event_Observer))
#5 /var/www/public/app/Mage.php(448): Mage_Core_Model_App->dispatchEvent('controller_acti...', Array)
#6 /var/www/public/app/code/core/Mage/Core/Controller/Varien/Action.php(531): Mage::dispatchEvent('controller_acti...', Array)
#7 /var/www/public/app/code/core/Mage/Adminhtml/Controller/Action.php(160): Mage_Core_Controller_Varien_Action->preDispatch()
#8 /var/www/public/app/code/core/Mage/Core/Controller/Varien/Action.php(407): Mage_Adminhtml_Controller_Action->preDispatch()
#9 /var/www/public/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(254): Mage_Core_Controller_Varien_Action->dispatch('index')
#10 /var/www/public/app/code/core/Mage/Core/Controller/Varien/Front.php(172): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#11 /var/www/public/app/code/core/Mage/Core/Model/App.php(354): Mage_Core_Controller_Varien_Front->dispatch()
#12 /var/www/public/app/Mage.php(684): Mage_Core_Model_App->run(Array)
#13 /var/www/public/index.php(87): Mage::run('', 'store')
#14 {main}

1 Answer 1

1

There are a couple of things that you should check. I assume that your server/environment is fast enough.

  1. Make sure that you've enabled the cache (System -> Cache Management)

  2. Make sure you've turned on WSDL caching (System -> Configuration -> Magento Core Api -> Enable WSDL Cache)

  3. Pay attention to Alan Storm's issue which he described at: https://stackoverflow.com/questions/14822866/magento-soap-api-working-locally-but-not-remotely#14823827

If nothing help, try to increase maximum execution time in php.ini, at least to be sure that it's working at all. http://php.net/manual/en/function.set-time-limit.php

1
  • I set max_execution_time to 180 in php.ini and it worked.
    – rits
    Mar 15, 2017 at 11:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.