0

I'm using Paypal Sandbox Account. I'm facing below issue

[2017-03-15 03:32:20] main.CRITICAL: Exception message: PayPal gateway has rejected request. Payment has already been made for this InvoiceID (#10412: Duplicate invoice).
Trace: #0 D:\wamp\www\magento\vendor\magento\framework\ObjectManager\Factory\Dynamic\Developer.php(89): Magento\Framework\ObjectManager\Factory\AbstractFactory->createObject('Magento\\Framewo...', Array)
#1 D:\wamp\www\magento\vendor\magento\framework\ObjectManager\ObjectManager.php(57): Magento\Framework\ObjectManager\Factory\Dynamic\Developer->create('Magento\\Framewo...', Array)
#2 D:\wamp\www\magento\var\generation\Magento\Framework\Exception\LocalizedExceptionFactory.php(43): Magento\Framework\ObjectManager\ObjectManager->create('\\Magento\\Framew...', Array)
2

By default Paypal does not allow you to put through the same invoice number twice. This can happen when you use the same credentials across multiple different Magento sites (even across a local environment and your staging environment)

You can change this behaviour in Paypal under Your Profile > Selling Tools > Block payments and then change the setting for Block accidental Payments to
"No, allow multiple payments per invoice ID"

block accidental payments

For me the direct link to the relevant settings is https://www.paypal.com/cgi-bin/customerprofileweb?cmd=_profile-pref

| improve this answer | |
  • Thank you so much @kristof fooman it is working perfect for me.... – Nagaraju K Jul 18 '17 at 13:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.