1

I've encountered a strange issue since moving our Magento installation to a new server.

While attempting to upload images for a new product it just seems to hang with the upload never completing:

Magento image upload issue

If I try to switch tabs a dialog pops up and says there are files that aren't uploaded yet.

I can upload from the WYSIWYG editor no problem though.

I have searched for several hours to find a solution but so far nothing has worked.

I've made sure the media folder has the correct permissions. I've tried various php.ini configurations suggested around the web. I've tried a no-flash uploader but it still behaves the same way.

I assume it's something to do with the new server as the problem only started once we switched.

Any help is greatly appreciated.

  • Any js error in console? – Marius Mar 7 '14 at 15:31
  • Nope, no JavaScript errors at all. – dekin88 Mar 7 '14 at 16:02
  • which browser u used? – Keyul Shah Mar 7 '14 at 17:18
1

Turns out the reason for the image upload not working was that the new server did not have the GD extension installed. Rebuilt Apache and PHP installation with GD and now all is well!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.