0

I have created a custom extension.

I created tabs in system > configuration tab to enable and disable of extension. Now options for enable and disable is visible in back end.

Now the extension is active but even selecting enable to 'no' at admin panel.

0

Try disabling the module after changing the configuration scope to website and store. If still it doesn't disable your module, then you have to disable it from app/etc/modules/your_module.xml

change <active>true</active> to <active>false</active>

  • I wish to disable it programmatically, when I select 'no' option in enable module option in configuration it should disable automatically. – user00247 Mar 10 '17 at 8:20
0

You can disable that new custom extension from your root folder.

For that,

  1. Goto your root folder > app > etc > .modules > your_extension.xml
  2. Change the status of that extension from <active>true</active> to <active>false</active>

You can see like,

   <config>
      <modules>
        <Your_Extension>
           <active>false</active>
           <codePool>community</codePool>
         </Your_Extension>
       </modules>
    </config>
  • 1
    I wish to disable it programmatically, when I select 'no' option in enable module option in configuration it should disable automatically – user00247 Mar 10 '17 at 8:21
0

this is just field containing value to yes no

You have to put condition all the places where you want to disable this functionality

$flag = Mage::getStoreConfig('sectionName/groupName/fieldName');
if($flag){
   // your code
}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.