1

Magento 1.9.3.1 - Catalog URL Rewrites - Index Management - Stuck in Processing.

I have had this happen in the past on earlier versions of Magento and I have been able to get one of the fixes already online to work (replace app/code/core/Mage/Catalog/Model/URL.php in Local with patch / code fixes) - I also have the Index Optimization module installed.

Nothing is fixing it this time. I am on a shared server with limited direct server shell access. Also - there is no file in the var/locks folder.

Any and all help/suggestions would be appreciated.

  • do you have SSH access for your directory/project ? – Murtuza Zabuawala Mar 10 '17 at 7:10
  • I do not have SSH access – Classic Mar 10 '17 at 7:47
  • Do you have access of cpanel ? – Murtuza Zabuawala Mar 10 '17 at 7:51
  • yes I do have cpanel access – Classic Mar 10 '17 at 8:04
  • check my answer – Murtuza Zabuawala Mar 10 '17 at 8:09
3

OK As you dont have SSH access and you cannot fire command directly,

so you can setup cron with your cpanel

just go to your cpanel and setup cron with near by time with below command

 php -f  /your_magento_dir/shell/indexer.php reindex

So choose your near time so cron run with in that time and your problem would solved.

  • 1
    Thanks so much for the help. This worked. I'm not sure why my reindex.php script/file wouldn't do the same thing, and I have been super busy and super tired. So, right now, I'm just happy to have this solved. – Classic Mar 11 '17 at 8:37
  • @Classic you are always welcome :) – Murtuza Zabuawala Mar 11 '17 at 9:05
2

Login to your mysql database through ssh and type "show processlist" and their comes an output simliar in the table and find the process id where their is continue execution of query related to core_url_rewrite. Once you get the process id you can kill this process using "kill id" (where id should replace with the process id).

Once successfully killing process id now refresh the indexmanagement page in the magento admin. you can see their is no indexing process which is stucked in Process. Now you can reindex it.

  • I do not have SSH access – Classic Mar 10 '17 at 7:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.