2

Something went wrong when I was using the Component Manager to install a module, and now I cannot see my front or back ends.

When I try to do anything through the CLI I get this message:

PHP Fatal error:  Uncaught Error: Class 'Zend_Cache' not found in /chroot/home/urbanta1/devm2.urbantactical.com/html/vendor/magento/framework/App/Cache/Frontend/Factory.php:148
Stack trace:
#0 /chroot/home/urbanta1/devm2.urbantactical.com/html/vendor/magento/framework/App/Cache/Frontend/Pool.php(67): Magento\Framework\App\Cache\Frontend\Factory->create(Array)
#1 /chroot/home/urbanta1/devm2.urbantactical.com/html/vendor/magento/framework/App/Cache/Frontend/Pool.php(146): Magento\Framework\App\Cache\Frontend\Pool->_initialize()
#2 /chroot/home/urbanta1/devm2.urbantactical.com/html/vendor/magento/framework/App/Cache/Type/FrontendPool.php(84): Magento\Framework\App\Cache\Frontend\Pool->get('default')
#3 /chroot/home/urbanta1/devm2.urbantactical.com/html/vendor/magento/framework/App/Cache/Type/Config.php(49): Magento\Framework\App\Cache\Type\FrontendPool->get('config')
#4 /chroot/home/urbanta1/devm2.urbantactical.com/html/vendor/magento/framework/Cache/Frontend/Decorator/Bare.php(65): Magento\Framework\App\Cache\Type\Config->_getFr in /chroot/home/urbanta1/devm2.urbantactical.com/html/vendor/magento/framework/App/Cache/Frontend/Factory.php on line 148

Can anyone tell me what to do? I have looked in the Factory.php, Pool.php etc and I can't tell what is wrong.

Thanks!

  • Do you have any custom cache implemented? That might need clearing – Dominic Xigen Jun 2 at 22:44
0

Check the code of the module you are trying to install.

I had the same error and it was because i had Magento core files inside one of the vendor modules. So this files were in conflict with the current installation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.