0

I am using Magento 1.7 on localhost over WAMP server.

I wanted to change the name of my store, and I did so by going to Admin -> System -> Configuration -> General -> Web -> Insecure / Secure. Here I changed from oldStoreName to newStoreName.

I also changed my store's folder name, under wamp64/www, from oldStoreName to newStoreName.

I also changed the name of the alias file (under wamp64/alias) to newStoreName.conf, and changed the places within the file where oldStoreName appears.

I cleared Magento's cache. I cleared var/session folder. I cleared my browser's cookies and cache.

I am able to access my admin page, 127.0.0.1/newStoreName/admin but whenever I try to access 127.0.0.1/newStoreName I get an error from the browser saying 'Too many redirects'.

I checked Apache's error log and found "apache client denied by server configuration local.xml", but after a bit of research it didn't seem to be related to my issue. Maybe it is?

*Edit: here's the code of .htaccess under myMagentoFolder/media/:

Options All -Indexes
<IfModule mod_php5.c>
php_flag engine 0
</IfModule>

# AddHandler cgi-script .php .pl .py .jsp .asp .htm .shtml .sh .cgi
Options -ExecCGI

<IfModule mod_rewrite.c>

############################################
## enable rewrites

    Options +FollowSymLinks
    RewriteEngine on

    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

############################################
## never rewrite for existing files
    RewriteCond %{REQUEST_FILENAME} !-f

############################################
## rewrite everything else to index.php

    RewriteRule .* ../get.php [L]
</IfModule>

Anyone has any hints on what the issue could be? I just changed my store's name, didn't modify more things that what I explain here. Any help is much appreciated.

  • Check Your .htaccess file for redirects – Konrad Siamro Mar 7 '17 at 10:21
  • As Konrad Siamro said, you should check .htaccess file if that is ok, remove the cache and try to reindex all the indexex ( it will be best if you could do it from CMD/shell ) – Vlad Patru Mar 7 '17 at 10:28
  • I don't really know what my .htaccess should look like. I am pretty new in this field. I just added my .htaccess code, could you please tell me if you see something wrong? – LeCodeur Mar 7 '17 at 11:16
  • Finally it was an issue related with an Observer that I'm using to prevent users from seeing some content before log in. – LeCodeur Mar 7 '17 at 12:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.