0

I wanted to make a copy of my site on my local server in order to use it as a development site. I made a backup of the database and restored it in the server, then I changed the values of web/unsecure/base_url and web/secure/base_url to point to my local server (http://xxx.xxx.xx.xxx/mySite/). I copied the whole directory into my server, then I proceeded to manually delete the content of sessions and cache and also I ran the re-indexing script. After that I changed the values of /app/etc/local.xml to point to my database. That's all the process, right? Well, nothing happened, I can't see my store. I got this error:

Warning: simplexml_load_string(): Entity: line 73: parser error : Opening and ending tag mismatch: reference line 72 and customer_logged_out  in /var/www/chromo/includes/src/__default.php on line 28352

#0 [internal function]: mageCoreErrorHandler(2, 'simplexml_load_...', '/var/www/chromo...', 28352, Array)
#1 /var/www/chromo/includes/src/__default.php(28352): simplexml_load_string('getFileLayoutUpdatesXml('frontend', 'chromo', 'default', '1')
#3 /var/www/chromo/includes/src/__default.php(28255): Mage_Core_Model_Layout_Update->fetchFileLayoutUpdates()
#4 /var/www/chromo/includes/src/__default.php(28154): Mage_Core_Model_Layout_Update->fetchPackageLayoutUpdates('default')
#5 /var/www/chromo/includes/src/__default.php(28132): Mage_Core_Model_Layout_Update->merge('default')
#6 /var/www/chromo/includes/src/__default.php(13760): Mage_Core_Model_Layout_Update->load()
#7 /var/www/chromo/includes/src/__default.php(11176): Mage_Core_Controller_Varien_Action->loadLayoutUpdates()
#8 /var/www/chromo/includes/src/__default.php(11119): Mage_Cms_Helper_Page->_renderPage(Object(Mage_Cms_IndexController), 'home')
#9 /var/www/chromo/app/code/core/Mage/Cms/controllers/IndexController.php(45): Mage_Cms_Helper_Page->renderPage(Object(Mage_Cms_IndexController), 'home')
#10 /var/www/chromo/includes/src/__default.php(13872): Mage_Cms_IndexController->indexAction()
#11 /var/www/chromo/includes/src/__default.php(18234): Mage_Core_Controller_Varien_Action->dispatch('index')
#12 /var/www/chromo/includes/src/__default.php(17768): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#13 /var/www/chromo/includes/src/__default.php(20368): Mage_Core_Controller_Varien_Front->dispatch()
#14 /var/www/chromo/app/Mage.php(683): Mage_Core_Model_App->run(Array)
#15 /var/www/chromo/index.php(87): Mage::run('', 'store')
#16 {main}

But I do have access to my backend. Any ideas of how to solve this?

Thanks.

1 Answer 1

1

Looks like the layout update xml for you homepage is not well formatted.
Go to the backend to CMS->Pages edit the homepage (the one with identifier home) and take a looks at the field Layout XML updates. Try to make the xml in there valid.

4
  • Thanks for answer. I checked the Layout XML Updates but I couldn't find anything that seemed wrong to me. Here's what I got: <reference name="head"> <block type="core/text" name="chromo_style"> <action method="setText"><text><![CDATA[<link href="/skin/frontend/chromo/default/css/chromo_style.css" rel="stylesheet" type="text/css" id="chromo_style">]]></text></action> </block> <block type="core/text" name="chromo_js"> <action method="setText"><text><![CDATA[<script src="/skin/frontend/chromo/default/js/chromo_js.js"></script>]]></text></action> </block> </reference>
    – Sebastian
    Mar 6, 2014 at 16:03
  • @Sebastian. I looked closely at the error message and just realized I was wrong. It looks like the error is in one of the layout xml files of your theme. Look in the layout files for the text customer_logged_out and see which one of the layout files that contains it is not valid.
    – Marius
    Mar 6, 2014 at 16:14
  • I checked those files, to be honest I don't know what am I looking for, everything looks normal to me. But I'm wondering, if the same files are working on my live server, why not here? I made an exact copy and just changed but I told you in the description, nothing else.
    – Sebastian
    Mar 6, 2014 at 17:07
  • My installation was originally on the root folder, the copy it's gonna be under /var/www/mySite, who should I point the intallation to /var/www/mySite?
    – Sebastian
    Mar 6, 2014 at 20:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.