2

I Installed Magento 2.2.0-dev through git clone.

I tried installing sample data by using Magento's method of cloning repositories http://devdocs.magento.com/guides/v2.0/install-gde/install/sample-data-before-clone.html#sample-clone

The sample data is installed and I can see everything in admin.

On front end, pages are blank. When I go to a category page I can see product filters but I cannot see any of products - content is blank.

When I run bin/magento setup:upgrade it seems to upgrade everything just fine but then at end it says

Please re-run Magento compile command. Use command "setup:di:compile" Start import: Nothing to import

I checked in list of modules and Module 'Magento_SampleData': is in list

What could I be missing?

UPDATE:

I set the store to development mode and then the items show. Only in production mode does it not show the items. Is sample data only meant to work in development mode?

| improve this question | | | | |
  • Check the permissions of "var" and "pub" folder and run below commands aagain. - php bin/magento setup:static-content:deploy – Abhishek Panchal Mar 20 '17 at 21:16
  • all I get is "We're sorry, an error has occurred while generating this email." – Haim Mar 20 '17 at 21:29
  • Please try to re-run your sample data again. – Abhishek Panchal Mar 20 '17 at 21:33
  • Thanks, will try. More important then getting it to show, I would like to know why it's currently not showing – Haim Mar 20 '17 at 22:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.