0

i havent changed any cookies settings that some people have mentioned to try. I did install memcache, im not sure if that is related.

local.xml

<config>
    <global>
        <install>
            <date><![CDATA[Fri, 17 May 2013 03:32:24 +0000]]></date>
        </install>
        <crypt>
            <key><![CDATA[RANDOMNUMBER]]></key>
        </crypt>
        <disable_local_modules>false</disable_local_modules>
        <resources>
            <db>
                <table_prefix><![CDATA[]]></table_prefix>
            </db>
            <default_setup>
                <connection>
                    <host><![CDATA[localhost]]></host>
                    <username><![CDATA[USERNAME]]></username>
                    <password><![CDATA[PASSWORD]]></password>
                    <dbname><![CDATA[DATABASE]]></dbname>
                    <initStatements><![CDATA[SET NAMES utf8]]></initStatements>
                    <model><![CDATA[mysql4]]></model>
                    <type><![CDATA[pdo_mysql]]></type>
                    <pdoType><![CDATA[]]></pdoType>
                    <active>1</active>
                </connection>
            </default_setup>
  <!-- START new connection to wordpress database !-->
            <wordpress_setup>
                <connection>
                    <host><![CDATA[localhost]]></host>
                    <username><![CDATA[USERNAME]]></username>
                    <password><![CDATA[PASSWORD]></password>
                    <dbname><![CDATA[DATABASE]]></dbname>
                    <initStatements><![CDATA[SET NAMES utf8]]></initStatements>
                    <model><![CDATA[mysql4]]></model>
                    <type><![CDATA[pdo_mysql]]></type>
                    <pdoType><![CDATA[]]></pdoType>
                    <active>1</active>
                    <use>0</use>
                </connection>
            </wordpress_setup>
            <!-- FINISH new connection to wordpress database !-->
        </resources>
        <session_save><![CDATA[db]]></session_save>
<cache>
               <backend>ewfile</backend>
           <slow_backend>ewfile</slow_backend>
          </cache>
    </global>
    <admin>
        <routers>
            <adminhtml>
                <args>
                    <frontName><![CDATA[ADMIN]]></frontName>
                </args>
            </adminhtml>
        </routers>
    </admin>
</config>

1 Answer 1

0

Memcached in theory shouldn't be used on your checkout. It potentially could cache user data and show it to someone else.

It sounds like your form key might be getting cached into memcached by another user and then when you visit/a separate customer visits the checkout they have the cached form key rather than their own.

It might be worth disabling memcached and then retrying the checkout, if it works then there is most likely something wrong in the configuration for memcached.

Some useful information regarding memcached configuration for magento: https://redislabs.com/lp/magento-memcached/

18
  • is there a way to create an exception within memcache so checkout is not cached?
    – Jackel2017
    Commented Mar 3, 2017 at 14:47
  • @DanCarylon im using it as shown in the link you provided
    – Jackel2017
    Commented Mar 3, 2017 at 14:48
  • Are you serving the checkout over https as this should not get cached and means there are other problems.
    – DanCarlyon
    Commented Mar 3, 2017 at 14:59
  • @Jackel2017 can you post your cache xml settings
    – DanCarlyon
    Commented Mar 3, 2017 at 15:07
  • yes, i use HTTPS at checkout. where is this setting? cache xml?
    – Jackel2017
    Commented Mar 3, 2017 at 15:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.