0

I'm getting the error below during my re-index:

The Flat Catalog module has a limit of 64$d filterable and/or sortable attributes.Currently there are 92$d of them.Please reduce the number of filterable/sortable attributes in order to use this module

How can I fix it? Is that a limit in MYSQL?

Any help is appreciated.

2 Answers 2

1

yes, it's limitation of mysql: A table can contain a maximum of 64 secondary indexes.https://dev.mysql.com/doc/refman/5.7/en/innodb-restrictions.html

Simple solution is not use flat indexex.

0

Another option is to change the default config value, that is currently used, in your own module. Create \Namespace\Module\etc\config.xml and put following into it

<config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        xsi:noNamespaceSchemaLocation="urn:magento:module:Magento_Store:etc/config.xsd">
    <default>            
        <catalog>
            <product>
                <flat>
                    <max_index_count>128</max_index_count>
                </flat>
            </product>
        </catalog>
    </default>
</config>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.