unable to open permissions_role page I get below error

-Class 'Mage_Ajaxsddto_Helper_Data' not found in E:\CUBE9-XAMPP\htdocs\boxed\app\Mage.php on line 547

already added below code 4/ Add it on the node like this:


5/ Create folder app/code/{community/local}/{Vendor}/Ajaxsddto/Helper folder if it doesn't exists and create file Data.php:

class Vendor_Ajaxsddto_Helper_Data extends Mage_Core_Helper_Abstract


any other resolution.

config.xml file

0.1.0 standard Etheme_Ajaxaddto ajax ajaxaddto.xml


  • Can you please add code of your config.xml
    – Piyush
    Mar 2 '17 at 6:47

1/ Search recursively for the word Ajaxsddto inside folders app/code/community/ and app/code/local/

2/ When you find the module, open his config.xml inside app/code/{community/local}/{Vendor}/Ajaxsddto/etc folder

3/ Search for the string <helpers>, normally you won't find it.

4/ Add it on the <global> node like this:


5/ Create folder app/code/{community/local}/Etheme/Ajaxaddto/Helper folder if it doesn't exists and create file Data.php:

class Etheme_Ajaxaddto_Helper_Data extends Mage_Core_Helper_Abstract


6/ Flush your Magento cache and test again.

  • 2
    after defining helper in config.xml you also have to add helper file (Data.php) in helper folder.
    – Piyush
    Mar 1 '17 at 13:20
  • already add <helpers> <ajaxsddto> <class>Vendor_Ajaxsddto_Helper</class> </ajaxsddto> </helpers> Mar 2 '17 at 6:31
  • I've updated point 4, don't forget to clear your Magento cache. Mar 2 '17 at 8:08
  • Is this solve your problem Mar 2 '17 at 8:32

It seems like there is a typo mistake in your code.
Search for keyword ajaxsddto in your files and replace it with ajaxaddto. I cant say which file contains the error so You need to search in all your files for this wrong keyword.
There is no helper defined with name ajaxsddto in your code.


I'm almost sure that you haven't disabled compilation (System -> Tools -> Compilation) before installing the extension. Looks like you have cleared cache and Magento took extension configuration files but does not see the php files.

If compilation is enabled, you need to recompile the source files by pressing the corresponding button on this page.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.