3

I'm new to Magento ( 2.4.1 ) Every time i make changes in template files i need to flush cache every time usin php magento cache:flush in CMD ... this is too much time taking... Very slow development... Any solution?

2
  • disable cache from system->Cache Management , select all cache then from dropdowb select disable and click on submit. then check Mar 1, 2017 at 11:40
  • 1
    if i disable cache then the situation get worst ... and page loading gets too much slow... Mar 1, 2017 at 11:59

2 Answers 2

4

If you are working only on template files, and changes aren't reflecting :

1) Go to system->Cache Management.

2) Select block_html and full_page Cache.

3) Disable it.

4) Clear var->cache and var->page_cache or

5) Do the same using CLI commands to clear cache.

Try this.

2
  • yes it is working... will it affect any thing to my admin pages? Mar 1, 2017 at 12:44
  • I don't think so, yes it will take a little longer to load the blocks but I think its acceptable in development phase. Moreover the front-end speed matters than admin. Mar 1, 2017 at 14:36
1

You can enable and disable cache from the admin panel and also using the below command (reference):

php bin/magento cache:disable
2
  • if i disable cache then the situation get worst ... and page loading gets too much slow... Mar 1, 2017 at 11:58
  • 1
    The Magento 2 cache management is use for the speed up the website and gathers configuration from all its modules, merges it, and saves to the cache. we need to enable the cache all time We don't need to flush cache every time, we need to flush cache if we add some modifications related to DB. Also you can merge the CSS and JS from admin panel to speed up website STORES -> Configuration -> ADVANCED -> Developer here is the options for merge and minify the CSS and JS files. Mar 1, 2017 at 12:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.