0

I'm on Magento 1.9.2.2 and getting the static block bug. As a work around I disable the blocks html cache, the problem goes away.

But every day something goes in and the block html cache gets invalidated and the bug reappears. I then have to disable the block html again, and the next day again, and the next day again.

I'm no programmer. How do I disable the cache permanently so it doesn't refresh and go into invalidate state?

I just want this bug to go a way so people can use my site.

1
  • Have you checked your blocks to insure that they are not setting a cache lifetime?
    – Rebel
    Commented Feb 27, 2017 at 16:40

1 Answer 1

-1

You need to search for this block in your theme XMLs and then

set Cache Lifetime to 1 second

for exemple (0 or null is not allowed):

<block type="core/template" name="my_block" template="class/block.phtml">
    <action method="setCacheLifetime"><lifetime>1</lifetime></action>
</block>
1
  • Of cousre you can et it to 0 ... plesae check linked question.
    – sv3n
    Commented Dec 6, 2018 at 21:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.