2

the website was working fine until i changed an email setting from the admin panel, all of a sudden the website only shows this error

1 exception(s):
Exception #0 (UnexpectedValueException): Setup version for module 'MagePal_GmailSmtpApp' is not specified

Exception #0 (UnexpectedValueException): Setup version for module 'MagePal_GmailSmtpApp' is not specified
#0 /h/s/ph/vendor/magento/framework/Module/DbVersionInfo.php(56): Magento\Framework\Module\DbVersionInfo->isModuleVersionEqual('MagePal_GmailSm...', '1.4.1')
#1 /h/s/ph/vendor/magento/framework/Module/DbVersionInfo.php(79): Magento\Framework\Module\DbVersionInfo->isSchemaUpToDate('MagePal_GmailSm...')
#2 /h/s/ph/vendor/magento/framework/Module/Plugin/DbStatusValidator.php(55): Magento\Framework\Module\DbVersionInfo->getDbVersionErrors()
#3 /h/s/ph/vendor/magento/framework/Interception/Interceptor.php(142): Magento\Framework\Module\Plugin\DbStatusValidator->aroundDispatch(Object(Magento\Framework\App\FrontController\Interceptor), Object(Closure), Object(Magento\Framework\App\Request\Http))
#4 /h/s/ph/var/generation/Magento/Framework/App/FrontController/Interceptor.php(26): Magento\Framework\App\FrontController\Interceptor->___callPlugins('dispatch', Array, Array)
#5 /h/s/ph/vendor/magento/framework/App/Http.php(135): Magento\Framework\App\FrontController\Interceptor->dispatch(Object(Magento\Framework\App\Request\Http))
#6 /h/s/ph/vendor/magento/framework/App/Bootstrap.php(258): Magento\Framework\App\Http->launch()
#7 /h/s/ph/index.php(39): Magento\Framework\App\Bootstrap->run(Object(Magento\Framework\App\Http))
#8 {main}
0

Try

php -f bin/magento module:enable --clear-static-content MagePal_GmailSmtpApp
php -f bin/magento setup:upgrade

hope its work for you

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.