I've manually added 20 configurable products to my store. All products use the same option for configuration, in my case "frame color." After creating the products, I went to their respective product pages and found that for about a third of the products, the ability to choose the frame color in the drop down box didn't work. Clicking on the Please choose an option drop down, shows no options available. I can find no problems with any of the simple products created. They appear identical in their setup between working configurations and those that don't.

Has anyone seen this before? Is it a known bug? If you've seen it and fixed it, I'd love to know what you did.

I've tried deleting the bad configurable products and their associated simple products and recreating them to no avail.

CE 2.1.4, no extensions installed except a theme.

This config works:

This config works

This config does not work:

config that doesn't work

  • Are all simple products enabled, in stock, product associated to a website and associated with configurable product? Have you run reindex? Please show some prints "Configurations". Feb 26, 2017 at 18:26
  • Yes to all of that.
    – Dave G
    Feb 26, 2017 at 18:27
  • Please show a print of "Configurations" section of your configurable product. Feb 26, 2017 at 18:36
  • @JonathanRibas I've edited the original post with one working configuration and one non-working configuration.
    – Dave G
    Feb 26, 2017 at 20:53
  • In the above example the difference between working and not working seems to be the use of / in both the SKU and attribute. Could well be a bug that can't handle / (for example the character would need to be especially escaped for JSON). Can you confirm that this holds for working vs non-working for the rest of your products? Feb 26, 2017 at 21:03

4 Answers 4


I checked the following scenario on 2.1.4 and couldn't reproduce it, all works as expected for me, product options are available on the storefront.

Please let me provide the steps I used and let me know if it's not the same as yours.

  1. I created a product attribute which has dropdown input type and named it "Size" with three values: S, M, L
  2. Cleaned cache
  3. Created a configurable product "Shirt" based on that "Size" attribute and used all those three values on Step 2 of Configurable Product Wizard
  4. Checked all the options like Stock Status, Quantity, Website assignment in order to verify that "Color Shirt" will be available on the Storefront
  5. Upon saving the "Color Shirt" I selected "Add configurable attributes to the current Attribute Set"
  6. Cleaned cache
  7. Then I created another configurable product "Pants" based on the same attribute "Size"
  8. On the Step 2 of Configurable Product Wizard I left S, M and L unchecked and created three more values XS, XL and XXL and selected them
  9. Checked all the options like Stock Status, Quantity, Website assignment in order to verify that "Pants" will be available on the Storefront
  10. Upon saving the "Color Shirt" I selected "Add configurable attributes to the current Attribute Set"
  11. Cleaned cache
  12. Went to the Storefront and checked both Products "Shirt" and "Pants"
  13. Both of them had options under "Please choose an option..."

What theme do you use? Is this issue reproducible for you without this theme installed?

  • This is helping. Thank you. My products have only two conifugurable options. I followed your advice and added the configurable options one at a time and then verifying them on the site. So far so good. I also have many custom, non-configurable attributes. I'm adding them one at a time to see where the process breaks down.
    – Dave G
    Feb 28, 2017 at 21:49
  • More frequent saves of the base configurable product attributes before adding configurable attributes has seemed to be the fix. I'll remain hopeful.
    – Dave G
    Feb 28, 2017 at 22:13

Turns out that adding attribute values via the config options section of the create configurable product page is a bad idea. Every product that wound up with a faulty configuration was due to using attribute values I added on that page vs the values I created when I first created the product attribute itself. The solution was to go into the product attribute and remove all values that I had added through the create configuration window, and then add them to the product attribute's options list and save the product attribute. No amount of product editing saved the bad product so I wound up deleting them and recreating them. They're working fine now.

I'm glad I learned this with only 20 configurable products created and not the 1,000 I'll have ultimately.

This feels like a big old bug to me.

  • 1
    Wtf. Why is this still a bug.
    – scrowler
    Oct 25, 2017 at 7:39

We just had this issue with a lot of products where the sizes could not be selected. The culprit was that these colors did not have a record in the eav_attribute_option_swatch table.

Once we manually added records for those colors, even if the eav_attribute_option_swatch.value was left as NULL the issue would go away.

This seems to be related to using the flat catalog.

This is the query we used to find the colors with issues:

    FROM eav_attribute_option o
LEFT JOIN eav_attribute_option_value v ON o.option_id = v.option_id
LEFT JOIN eav_attribute_option_swatch s ON o.option_id = s.option_id
AND s.swatch_id IS NULL
AND v.store_id = 0

After that we simply ran:

INSERT INTO eav_attribute_option_swatch 


  • Thanks, I had this issue too. I'm still also unable to change the "Catalog Input Type" from swatch to dropdown, which is annoying.
    – WackGet
    Apr 17, 2019 at 17:45

Do you have inventory available for the simple products that make up the configurable ones? If not, those options may not be available on the front end to end users (based on your inventory settings).

That's the first thing that I'd recommend. I'd also make sure to reindex / flush cache, etc, even if you're in developer mode.

I hope this helps...

  • Yes. Inventory available, in stock, etc., for all products. Indexer runs via cron every minute. Cache flushed routinely.
    – Dave G
    Feb 26, 2017 at 18:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.