0

Very basic Magento developer here and have tried googling/searching for this with poor results. Just took over the site so unsure of the history...

Any Link (i.e. navigation item, product) or Redirect (i.e. after logging into /admin) turns into a 404 Not Found because, for some reason, after the domain.com, "/skin" is being appended to each url like so

mystore.com mystore.com/skin/product-page.html mystore.com/admin --> after login --> mystore.com/skin/...

If I remove /skin from the URL, the pages load fine so the site is working, just the URL structure is off somehow.

Anyone ever run into something like this? Thanks for reading!

2

Check your settings under

System > Configuration > Web > Unsecure (potentially also under Secure)

Especially check that skin/ is not part of Base Link URL it should normally only be used in the Base Skin URL setting.

  • Thanks much! That is most likely it but the issue actually prevents me from changing it. When I remove the /skin (its only on secure) and Save Changes, it doesn't save because it redirects to an admin URL with /skin after the .com, going to a 404. Is my only option manually editing this in the database? – user5546 Mar 5 '14 at 0:39
  • yes if you can't access the admin to change it, you would need to change it directly in the database. Take a look at the core_config_data table. – Kristof at Fooman Mar 5 '14 at 1:52
0

Check system -> configuration -> web -> unsecure in admin and make sure that the Base URL doesn't have "/skin" and ends with "/".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.